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Introduction 
ROCFALL is a statistical analysis program designed to 
assist with a risk assessment of slopes at risk of rockfalls. 
Energy, velocity and "bounce height" envelopes for the 
entire slope are determined by the program as is the 
location of rock endpoints. 

ROCFALL can also assist in determining remedial 
measures: the material properties of each slope segment 
can be changed and the analysis re-run, comparing the 
results. Information about the kinetic energy and location 
of impact on a barrier can help determine the capacity, 
size and location of barriers. 

ROCFALL provides various ways of interacting with other 
Windows programs. All input and output data (formatted 
in tabular form) and screen captures, can be "pasted" into 
a word processor for speedy report writing. ROCFALL 
also allows "raw" data (e.g. the impact location on a 
barrier) to be "pasted" into a spreadsheet for more 
detailed analysis. (e.g. determining what fraction of the 
impact locations were above a certain height; or fitting a 
probability distribution to the data). 

About this Manual 

This manual consists of the following tutorials: 

1. A Quick Start tutorial, to get new users acquainted 
with the basic features of ROCFALL. 

2. A Barriers and Collectors tutorial. 

3. A Vertex Variation tutorial. 
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This manual is intended as a hands-on, getting started 
user’s guide. For more information on any ROCFALL 
options that are not discussed in these pages, consult the 
ROCFALL Help system.  

In this manual, instructions such as: 

Select: Slope → Define Slope 

are used to navigate the menu selections. 

Toolbar buttons are displayed in margins (as shown 
above) only if the option being described is available in a 
ROCFALL toolbar. The toolbar button is always the 
recommended and quickest way to use the option. 
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Quick Start Tutorial 

 

This “quick start” tutorial will demonstrate the basic 
features of the program, and show you how to perform a 
basic RocFall. 

If you have not already done so, run ROCFALL by double-
clicking on the ROCFALL icon in your installation folder. 
Alternatively, from the Start menu, select Programs → 
Rocscience → RocFall → RocFall. 

If the ROCFALL application window is not already 
maximized, maximize it now, so that the full screen is 
available for viewing the model. 

Analysis Overview 

A typical ROCFALL analysis can be performed in a few 
minutes, and will consist of the following steps: 
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1. Define the slope. 

2. Define the slope materials. 

3. Assign the materials to the slope segments. 

4. Define the rock starting locations (seeders). 

5. Compute the analysis. 

6. Graph the results. 

In addition, Barriers and Data Collectors can be defined, 
as discussed in Tutorial 2. This Quick Start Tutorial will 
take you through the basic steps 1 – 6 outlined above, to 
perform a simple ROCFALL analysis. Note: the model 
created in this tutorial can also be found in the 
SIMPLE.FAL file in the EXAMPLES folder in your 
ROCFALL installation folder. 

Defining the Slope 

Before we begin, notice that when the ROCFALL program 
is started, a new blank document is already opened. This 
allows you to begin creating a model immediately. The 
initial view shown on your screen is known as the slope 
view. 

The user can create a new document at any time, by 
selecting the New option from the File menu or the 
toolbar. 

Limits 
Before we define the slope, let’s set the limits of the 
drawing region, so that we can see the slope being created 
as we enter the geometry. 

Select: View → Limits 
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Enter the following minimum and maximum x-y 
coordinates in the View Limits dialog: 

 

Figure 1-1: View Limits dialog. 

These limits will approximately center the slope in the 
drawing region, when you enter it as described below. 

Define Slope 
To create the slope, select Define Slope from the Slope 
menu or the toolbar. 

Select: Slope → Define Slope 

Enter the following coordinates in the prompt line at the 
bottom right of the screen.  

Enter vertex [enter=done]: 0 0
Enter vertex [enter=done]: 3.1 –12.2
Enter vertex [enter=done]: 6.7 –12.2
Enter vertex [enter=done]: 9.8 –24.4
Enter vertex [enter=done]: 13.4 -25
Enter vertex [enter=done]: 21.3 –23.5
Enter vertex [enter=done]: press Enter
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Note that pressing the Enter key enters each coordinate 
pair. When the last vertex has been entered, pressing the 
Enter key again adds the slope to screen, and exits the 
Define Slope option. 

The slope can also be created graphically in ROCFALL, by 
simply clicking the left mouse button at the desired 
coordinates while using Define Slope. (The Grid and Grid 
Snap options are helpful for entering exact coordinates 
graphically.) 

Reset the slope view by selecting Zoom All from the 
toolbar (or you can press the F2 function key to Zoom All). 
Your screen should now look as follows: 

 

Figure 1-2: Slope geometry defined. 
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Defining Materials 

To define the slope material properties, select Material 
Editor from the toolbar or the Slope menu. 

Select: Slope → Material Editor 

 

Figure 1-3: Material Editor dialog.  

In the Material Editor dialog, you will notice that a 
number of default materials have been pre-defined for 
your convenience. However, for this tutorial, we will 
define three new materials, as described below.  

1. Select the Add button in the Material Editor dialog, 
and notice that “New Material” appears in the 
Existing Materials list. 

2. Change the name of this new material to Type One, 
and enter the properties given in Table 1-1. 

3. Repeat steps 1 and 2 to define two more new 
materials named Type Two and Type Three. See Table 
1-1 for properties. 
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Name 
Rn 

(mean | 
sd) 

Rt 
(mean | 

sd) 

Phi 
(mean | 

sd) 

Rough-
ness (sd) Color 

Type One 0.8 | 0.03 0.8 | 0.03 30 | 0 0 Black 

Type Two 0.7 | 0.03 0.8 | 0.03 30 | 0 0 Green 

Type Three 0.5 | 0.03 0.5 | 0.03 30 | 0 0 Pink 

Table 1-1: New material properties. 

4. When you are finished entering all of the properties, 
select the Done button in the Material Editor dialog. 

You are now ready to assign the material properties to the 
slope. 

NOTE: 

• Standard deviations are NOT mandatory. If you 
would like a property specified “exactly” by it’s mean 
value, then simply enter a standard deviation of 0.0 
(zero) for that property. 

• Slope colours have no bearing on the analysis. They 
are simply used for identification purposes. 
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Assigning Materials 

Material properties are assigned to the slope segments 
with the Slope Editor dialog, available in the Slope menu. 
You can also invoke the Slope Editor dialog by double-
clicking on a slope vertex. (Materials can also be assigned 
graphically with the mouse. This is described in the next 
section). 

Select: Slope → Slope Editor 

Let’s assign our newly defined materials (Type One, Type 
Two and Type Three) as follows: 

1. In the Slope Editor dialog, double click the mouse in 
the SECOND row of the Material column, and select 
Type One from the drop-down list of available 
materials. This will assign the material Type One to 
the SEGMENT between vertices 1 and 2. 

2. Double click the mouse in the THIRD row of the 
Material column, and select Type Two. This will 
assign the material Type Two to the SEGMENT 
between vertices 2 and 3. 

3. Proceed in this manner, until the materials are 
assigned as shown in Figure 1-4. Click OK when done. 

 

Figure 1-4: Slope Editor dialog. 
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Graphical Method of Assignment 
Although we illustrated the slope material assignment 
using the Slope Editor dialog, material assignment can 
also be done graphically with the mouse, using: 

• The “Assign” toolbar button (the “paintbrush” button) 
in the toolbar, in conjunction with the pull-down list 
of material names.  

 

In most cases you will find it easier to graphically assign 
materials, rather than use the Slope Editor dialog. To 
assign materials graphically, simply: 

1. Select the Assign toolbar button. 

2. Select a material from the list in the toolbar. 

3. Select slope segments with the left mouse button. 
(Multiple segments can be selected with a selection 
window. Click AND HOLD the left mouse button and 
drag to create a window). 

4. When finished, press the Enter key or right-click the 
mouse and select Done. 

Tip: 

If you right-click the mouse on a slope segment and select 
Assign Material, this will display the Slope Editor dialog, 
with the current material for the clicked-on segment 
already highlighted. Use the Slope Editor dialog as 
described previously, to assign a different material. 
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Data Tips 
“Data tips”, which appear when you place the cursor for a 
few moments over entities of the model, are a useful 
feature of ROCFALL. 

For example, if you place the cursor over a segment of the 
slope, the material properties of the slope segment will be 
displayed, as illustrated below. 

 

Figure 1-5: Data tip for slope properties. 

If you place the cursor directly over a vertex of the slope, 
the data tip will display the x-y coordinates of the vertex 
(and the standard deviations used, if any). 
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Figure 1-6: Data tip for vertex coordinates. 

Data tips allow you to quickly check on model properties 
onscreen while viewing the model, without having to 
return to the data input dialogs, etc. 

Data tips are available for all ROCFALL model entities, 
also including seeders, barriers and data collectors. 
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Defining Rock Seeders 

The final mandatory step to complete a ROCFALL model 
is to define the initial conditions for the rocks (location, 
mass and velocity). 

Rock starting locations can be defined as either: 

• POINTS (Add Point Seeder option) or  

• LINES (Add Line Seeder option). 

For this tutorial, we will simply add a single point seeder 
(ie. All rocks will originate from one location). Select Add 
Point Seeder from the toolbar or the Rocks menu. 

Select: Rocks → Add Point Seeder 

1. Right-click the mouse and select Vertex Snap from the 
popup menu.  

2. Move the cursor near the first slope vertex (ie. the 
vertex at 0 , 0). When the cursor is close to the vertex, 
it will “snap” to the exact location of the vertex (since 
we turned Vertex Snap on in step 1). 

3. When the cursor (blue cross) is snapped to the vertex, 
click the left mouse button, and the Define Initial 
Conditions dialog will appear. 
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Figure 1-7: Define Initial Conditions dialog. 

Enter a Mean Horizontal velocity = 1.5 and a standard 
deviation = 0.15. Leave all other parameters as shown in 
Figure 1-7. Select OK when done. 

Note that “data tips” are also available for the rock seeder. 
Hover the mouse over the point seeder at (0 , 0) and you 
should see the initial conditions we just defined. 

 

Figure 1-8: Data tip for seeder properties. 
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Compute 

To run the ROCFALL analysis, select the Compute option 
from the Rocks menu or the toolbar. 

Select: Rocks → Compute 

The calculation should only take a few seconds or less, 
and your screen should look similar to Figure 1-9.  

 

Figure 1-9: Results of ROCFALL analysis (50 rocks). 

If your results appear slightly different from those in 
Figure 1-9, remember that by default, ROCFALL uses 
Random number generation during the analysis, and 
therefore results will be different each time the analysis is 
run. Reproducible results can be obtained by using the 
Pseudo-Random option, as discussed later in this tutorial. 

For this analysis, the default number of 50 rocks was 
used. This simulation parameter is found in the Project 
Settings dialog, and will be discussed later in this tutorial. 
However, let’s graph some results first. 
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Graphing the Results 

The horizontal location of endpoints is one of the most 
common and easily understood results from a ROCFALL 
analysis. 

Select: Graph → Endpoints 

Your screen should look similar to Figure 1-10. 

 

Figure 1-10: Endpoints graph (split-screen view). 

By default, when a graph is first generated in ROCFALL, 
it is presented in a Split View format, with the slope 
shown in the lower half of the screen as a visual reference. 
(NOTE that the slope is vertically compressed in this 
view, ie. the X and Y axes are not to the same scale). 

The Split View mode can be toggled on or off at any time, 
by selecting the Split View option from the toolbar or the 
Graph menu. 

Select: Graph → Split View 
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The graph is now maximized in the view. 

Chart Properties 
Right-click on the graph and select Chart Properties.  

 

Figure 1-11: Chart Properties dialog. 

The Chart Properties dialog allows the user to customize 
the vertical and / or horizontal ranges, as well as axis and 
graph titles. This is left as an optional exercise. Select OK 
or Cancel. 

Statistics 
Right-click on the graph and select Statistics. A dialog 
displaying graph statistics will be displayed, as shown in 
Figure 1-12.  

Scroll down to view the information in the Statistics 
dialog. 
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Notice the Copy button in the Statistics dialog. Selecting 
this button allows you to copy the information in the 
Statistics dialog, to the Windows clipboard. From the 
clipboard, it can be pasted into word processing or 
spreadsheet programs, for further analysis, or report 
writing. 

Select OK to close the Statistics dialog. 

 

Figure 1-12: Distribution Statistics dialog. 

Copy Raw Data 
In the Edit menu, you will notice a Copy Raw Data option. 
This allows the user to copy the raw data used to generate 
graphs, to the Windows clipboard. From the clipboard, the 
raw data can be pasted into word processing or 
spreadsheet programs, for further analysis, or report 
writing. This allows you, for example, to perform “custom” 
analyses that are not available with ROCFALL. For 
instance you could copy the “raw” data associated with the 
rock endpoints into your spreadsheet, sort the data and fit 
an unusual probability distribution to the data. 
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Envelope Graphs 
Kinetic Energy (Total, Translational, and Rotational), 
Velocity and Bounce Height envelopes can also be 
generated for ROCFALL analyses.  

Select: Graph → Graph Envelope  

The Graph Envelope dialog appears. It has a drop down 
list of the various envelopes that can be plotted.  

 

Figure 1-13: Graph Envelope dialog. 

Select Total Kinetic Energy from the list and click on the 
Create Graph button to view the results. 

 

Figure 1-14: Kinetic Energy Envelope (Split View toggled OFF). 
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Note: 

• Each graph is initially generated with the Split View 
option toggled ON. This can be toggled ON or OFF at 
any time, as described earlier for the Endpoints 
graph. 

• When the Kinetic Energy, Velocity or Bounce Height 
graphs are initially generated, a new view is created 
for each graph. Only one view of each graph type can 
exist. If these graph types are re-selected AFTER a 
graph has been created, the active view will simply 
revert to the selected graph. A new view will NOT be 
generated in this case.  

Distribution Graphs 
Kinetic Energy (Total, Translational, and Rotational), 
Velocity and Bounce Height distribution graphs can be 
generated. 

The distribution graphs show the distribution of results at 
X locations (horizontal locations) along the slope.  

Select: Graph → Graph Distribution 

The Graph Distribution dialog, with a drop down list of 
distribution graphs, will appear. 

 

Figure 1-15: Distribution Plot dialog. 
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Select Total Kinetic Energy from the dropdown list and 
select Create Graph.  

Your screen should appear similar to Figure 1-16. 

 

Figure 1-16: Kinetic Energy Distribution at x = 10.6. 

Note the following properties of the distribution graph: 

• A thick vertical line on the slope marks the X location 
of the data sampling. To sample data at other 
locations, simply click the left mouse button anywhere 
on the slope. The vertical line will indicate the 
selected position, and the graph will immediately be 
updated.  

• If you click AND HOLD the left mouse button on the 
slope, you can drag the vertical line marker along the 
slope, and the graph will be updated as the line is 
moved.  

• The sampling location can also be moved with the 
left/right arrow keys, or the mouse wheel (if your 
mouse has a mouse wheel). 



22 ROCFALL User’s Guide 

 

Adjusting the Sampling Locations 

The X locations of the data sampling are determined by 
the horizontal extent of the slope divided by the Number 
of Sampling Intervals in the Project Settings dialog. In 
general, these X locations will not be round numbers. 

To obtain round numbers for the X locations of the data 
sampling on the distribution graphs, you can: 

• adjust the Number of Sampling Intervals in the 
Project Settings dialog, and / or  

• modify the total X extent of the slope (eg. extend or 
shorten the first or last segment so that the total 
horizontal extent of the slope is a round number.)  

EXAMPLE: if the total X extent of the slope is 50 meters, 
and the Number of Sampling Intervals is 100, this will 
provide sampling at 0.5 meter intervals along the slope). 

Distributions at exact X locations can also be obtained by 
defining Data Collectors at the desired locations, and 
graphing the results for the collector(s). See the Barriers 
and Collectors tutorial for details. 
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Tiling the Views 
If you wish, you can now tile the views. 

Select: Window → Tile Vertically 

Depending on how many graphs you have generated, and 
whether or not you have the Split View option toggled on 
or off on each view, your screen may look something like 
Figure 1-17. 

 

Figure 1-17: Tiled views. 
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Re-running the Analysis 

You can re-run the analysis by re-selecting the Compute 
option as many times as desired. 

Select: Rocks → Compute 

All views and graphs will be updated with the cumulative 
results of all rocks thrown. Note that the total number of 
rocks thrown is displayed in the status bar. (For example, 
if you selected Compute five more times, the status bar 
would indicate 300 rocks thrown). 

 

Clearing the Rock Paths 
To start a new ROCFALL analysis with a clean slate, 
select the Clear Rock Paths option from the toolbar or the 
Rocks menu.  

Select: Rocks → Clear Rock Paths 

This will erase all existing rock paths on the slope, and 
erase all previously collected data. Any graph views that 
may have been open will indicate “No Data Available”. 

Note that ROCFALL automatically clears the rock paths 
any time that changes are made to the model, which would 
invalidate the currently displayed results. For example, if 
a new material is assigned to a slope segment, ROCFALL 
will automatically reset the rock paths. 
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Project Settings 
For this Quick Start tutorial, we have so far used the 
default simulation parameters. Let’s now change some of 
the simulation parameters in the Project Settings dialog, 
and re-run the analysis. 

Select: Rocks → Project Settings 

 

Figure 1-18: Project Settings dialog. 

Change the Number of Rocks to Throw to 500, and change 
the Number of Sampling Intervals to 100. Select OK. 

Re-run the analysis again (select Compute), and plot 
graphs as before. 

Note the speed of the analysis (500 rocks should still only 
take a few seconds to compute). It is important to note 
that the Number of Sampling Intervals is used during the 
ROCFALL calculations, and determines the frequency of 
data collection along the rock paths, and also affects the 
speed of the analysis. Any time the Number of Sampling 
Intervals is changed, a new ROCFALL analysis must be 
performed (previous results will automatically be erased. 
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Pseudo-Random Simulation 

By default, ROCFALL uses true Random number 
generation to sample the input data distributions you 
have defined for material properties etc. This means that 
each time Compute is selected, the analysis results will be 
different, and different rock paths will be generated. This 
is because a different “seed” number is used each time the 
random number generator is called. 

However, there may be times when you wish to generate 
reproducible results for a ROCFALL analysis. The 
Pseudo-Random option in the Project Settings dialog 
allows this. 

Pseudo-Random simulation means that the SAME "seed" 
number is always used to generate random numbers for 
the sampling of the input data distributions. This results 
in identical sampling of the input data distributions, each 
time the analysis is run (with the same input 
parameters). This can be useful for demonstration 
purposes, the discussion of example problems, etc. 

To demonstrate Pseudo-Random sampling: 

Select: Rocks → Project Settings 

Select the Pseudo-Random option and select OK. 

Now select Compute several times. Notice that the rock 
paths DO NOT CHANGE when Compute is selected, 
because the input data sampling is now Pseudo-Random 
instead of Random. 

Finally, notice that in the Project Settings dialog, a user-
specified seed number can be entered for the Pseudo-
Random option. Changing the seed number will give 
different analysis results. However, for a given seed 
number, results will always be the same (ie. Pseudo-
Random). This is left as an optional exercise for the user 
to experiment with. 
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Exporting Images 

In ROCFALL, various options are available for exporting 
image files. 

Export Image File 
The Export Image File option in the File menu or the 
right-click menu, allows the user to save the current view 
directly to one of four image file formats: 

• JPEG (*.jpg) 
• Windows Bitmap (*.bmp) 
• Windows Enhanced Metafile (*.emf) 
• Windows Metafile (*.wmf) 

Copy to Clipboard 
The current view can also be copied to the Windows 
clipboard using the Copy option in the toolbar or the Edit 
menu. This will place a bitmap image on the clipboard, 
which can be pasted directly into word or image 
processing applications. 

Black and White Images (Grayscale) 
A useful option in ROCFALL is the Grayscale option, 
available in the toolbar, the right-click menu or the View 
menu. This will automatically convert the current view to 
Grayscale, suitable for black and white image 
requirements. This is useful when sending images to a 
black and white printer, or for capturing black and white 
image files. 

The Grayscale option works as a toggle, and previous 
colour settings of the current view will be restored when 
Grayscale is toggled off 
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Info Viewer 

The Info Viewer option in the File menu and the toolbar, 
displays a summary of all ROCFALL model parameters in 
its own view. This includes: 

• Slope geometry 
• Slope materials 
• Seeder properties 
• Simulation parameters 
• Barrier and collector properties 

Select: File → Info Viewer 

 

Figure 1-19: ROCFALL Info Viewer listing. 

The Info Viewer information can be copied to the 
clipboard using the Copy option in the toolbar or the Edit 
menu, or by right-clicking in the view and selecting Copy 
to Clipboard. From the clipboard, the information can be 
pasted into word processing programs for report writing.  
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The Info Viewer information can also be sent directly to 
your printer using the Print option in the File menu. 

NOTE that analysis results are NOT recorded in the Info 
Viewer. However, as discussed earlier in this tutorial: 

• Graph results can be copied to the clipboard with the 
Copy Raw Data option in the Edit menu.  

• Graph statistics are available with the Statistics 
option in the Graph menu. 

 

Saving ROCFALL Models 

Before concluding this Quick Start Tutorial, we will save 
our ROCFALL model. 

Select: File → Save 

We will enter the name QuickTutorial.fal for our file. 

This brings us to the end of this Quick Start Tutorial. To 
exit the program: 

Select: File → Exit 
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Barriers and Collectors Tutorial 

 

This tutorial will demonstrate how to add Barriers and 
Collectors to a ROCFALL model, and interpret the 
results.  

If you have not already done so, run ROCFALL by double-
clicking on the ROCFALL icon in your installation folder. 
Or from the Start menu, select Programs → Rocscience → 
RocFall → RocFall. If the ROCFALL application window 
is not already maximized, maximize it now, so that the 
full screen is available for viewing the model. 

We will start with the same model we created in the 
previous “quick start” tutorial. This file is available in the 
SIMPLE.FAL file in the EXAMPLES folder in your 
ROCFALL installation folder. 

Select: File → Open 
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Navigate to the EXAMPLES folder in your ROCFALL 
installation folder, and open the SIMPLE.FAL file.  

Barrier Overview 

A Barrier in ROCFALL is a line segment with one end on 
the slope surface, which can be placed anywhere along the 
slope in order to alter the paths of the rocks as they travel 
down the slope.  

Barrier properties may be defined as: 

• Perfectly Inelastic (Rn=Rt=0) 
• Perfectly Elastic (Rn=Rt=1) 
• Custom (any intermediate coefficients of restitution 

between 0 and 1). 
• In addition, barriers can be assigned a breaking 

capacity in terms of the maximum energy before rocks 
break through. 

Any number of barriers can be added to the slope. 
Barriers, however, cannot cross other barriers and cannot 
cross slope segments. 

Adding a Barrier 

To add a barrier to the slope, select the Add Barrier 
option from the Barriers menu or the toolbar. 

Select: Barriers → Add Barrier 

Since the first point of a barrier line segment must always 
be on an existing slope segment, you will notice a cross 
marker move along the slope as you move the cursor. This 
marker indicates the point on the slope nearest to the 
cursor location, and is an aid for graphically adding the 
first barrier vertex to the slope by clicking the left mouse 
button. 
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However, for this example, we will enter exact coordinates 
in the prompt line, since it is difficult to enter exact 
coordinates graphically. 

Select location for the first endpoint
[esc=cancel]: 17.35 –24.25
Select location for the second endpoint
[esc=cancel]: 17.35 –17 

Your model should now look like Figure 2-1: 

 

Figure 2-1: Barrier added to slope. 

As you can see, we have added a vertical barrier at the 
midpoint of the last segment of the slope. 

You will also notice that the existing rock paths, which 
were present when we loaded the file, were reset when 
the barrier was added. This is done automatically by 
ROCFALL, since a new analysis is required whenever a 
barrier (or a data collector) is added to the model. 
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Default Barrier Properties 
When a barrier is first added in ROCFALL, the default 
properties of the barrier are Perfectly Inelastic (Rn = Rt = 
0.0). 

Barrier properties can be changed in the Barrier Editor 
dialog. This will be discussed shortly. However, let’s first 
run the analysis using the default properties. 

Compute 

Run the analysis by selecting the Compute option from 
the toolbar or the Rocks menu. 

Select: Rocks → Compute 

The calculation should only take a few seconds, and your 
screen should look similar to Figure 2-2.   

 

Figure 2-2: ROCFALL analysis with barrier. 
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Since the barrier is “perfectly inelastic” all rock paths 
which intersect the barrier come to a complete stop. The 
rocks do NOT rebound, but simply fall straight down to 
the bottom of the barrier, and come to rest. 

As an optional exercise, you can verify this by: 

• Zooming in to the barrier (use the Zoom Window 
option) and observing the rock path intersections with 
the barrier. 

• Plot an Endpoints Graph (select Graph→ Endpoints) 
and observe that nearly all rock paths terminate at 
the barrier (a few bounce short and fall back down the 
slope). See Figure 2-3. 

 

Figure 2-3: Endpoints Graph (Perfectly Inelastic barrier). 

If you performed the above optional steps, close the 
Endpoints Graph, and reset the slope view by selecting 
Zoom All from the toolbar (or you can press the F2 
function key to Zoom All). 
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Changing the Barrier Properties 

Barrier properties can be modified with the Barrier Editor 
dialog. This is available through the Barriers menu, 
however, a convenient shortcut is to right-click on a 
barrier, and select Edit Barrier from the popup menu. Do 
this now. 

Change the barrier from Perfectly Inelastic (Rn = Rt = 0) 
to Perfectly Elastic (Rn = Rt = 1). Select the Perfectly 
Elastic checkbox, and select Done. 

 

Figure 2-4: Barrier Editor dialog. 

Now re-run the analysis. 

Select: Rocks → Compute 

As described in the previous section, use Zoom Window to 
zoom in to the barrier and observe the rock paths. Since 
the barrier is Perfectly Elastic, all rocks now bounce off 
the barrier, and no longer “stick” to the barrier, as they 
did when the properties were Perfectly Inelastic. 

This will be evident if you view the Endpoints Graph. 

Select: Graph → Endpoints 

Compare Figures 2-3 and 2-5. As you can see, the rocks 
now bounce off the barrier and come to rest at various 
locations to the left of the barrier. 
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Figure 2-5: Endpoints Graph (Perfectly Elastic barrier). 

Close the Endpoints Graph, and if you zoomed in to the 
barrier as suggested earlier, press F2 to Zoom All. 

Of course, real barriers are not Perfectly Elastic or 
Perfectly Inelastic. 

As an optional exercise, select the Custom checkbox in the 
Barrier Editor dialog, and enter values between 0 and 1 
for the Normal and Tangential Coefficients of Restitution, 
and re-run the analysis. 

Barrier Capacity 
Barriers in ROCFALL can be assigned a capacity in terms 
of the energy required to break through the barrier. Any 
rocks that contact the barrier with a kinetic energy 
exceeding the barrier capacity will pass through the 
barrier, with a reduced velocity. Let’s demonstrate this. 

1. Right click on the barrier, and select Edit Barrier. 
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2. In the Barrier Editor dialog, de-select the Infinite 
Capacity checkbox, enter a capacity = 100 Joules, and 
select Done. 

3. Re-run the analysis (select Compute), and observe 
that some rock paths now pass through the barrier. 
Use Zoom Window to zoom in to the barrier, as shown 
in Figure 2-6.  

 

Figure 2-6: Rocks passing through barrier with finite capacity. 

Before we continue, reset the barrier capacity to Infinite 
in the Barrier Editor dialog. Press F2 to Zoom All. Select 
Compute to re-run the analysis. 

Graphing Barrier Results 

For each barrier, the following graphs can be plotted for 
rocks that strike the barrier: 

• Total Kinetic Energy 

• Translational Kinetic Energy 
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• Rotational Kinetic Energy 

• Translational Velocity 

• Rotational Velocity 

• X or Y (horizontal or vertical) impact locations on the 
barrier 

Select the Barrier and Collector Graphs option from the 
toolbar or the Graph menu. 

Select: Graph → Barrier & Collector Graphs 

In the Graph dialog, select Vertical Impact Location from 
the pull down list, and select Done.  

 

Figure 2-7: Graph dialog for Barriers and Collectors. 

• Note – the Horizontal Impact Location graph is not 
available, since the barrier in this case is vertical.  

Similarly, using the Graph dialog, plot graphs of Total 
Kinetic Energy and Translational Velocity.  

You have now generated three graphs for the barrier. Tile 
the views so that you can view all graphs at once.  

Select: Window → Tile Vertically 

Your screen should look similar to Figure 2-8. 
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Figure 2-8: Barrier graph results. 

• Note – the X or Y impact locations are plotted in terms 
of the absolute coordinates of your model. 

A shortcut for generating Barrier Graphs, is to right-click 
on a barrier, and select the desired graph. 

As an optional exercise, select Compute several times, and 
observe that all graphs are immediately updated to reflect 
the cumulative results of all rocks generated by the 
analysis. 

When you are finished examining the graphs, close the 
three graph views, and maximize the Slope view.  

That concludes this introduction to barriers in ROCFALL. 
We will now move on to a discussion of Data Collectors. 
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Data Collectors Overview 

A “data collector” in ROCFALL is simply a line segment 
that gathers information about rocks, passing through the 
segment while falling down the slope.  It is not a physical 
entity. “Data collectors” record the velocity, kinetic 
energy, vertical location, and horizontal location of all 
rocks that pass through as they travel down the slope.  

• Unlike barriers, data collectors do not affect the 
movement of the rocks in any way.  

• Data collectors do not have any properties associated 
with them (other than the endpoints defining their 
location), and do not have any directionality (i.e. it 
doesn’t matter which end is the starting point and 
which end is the ending point).  

• There is no restriction on the number of data 
collectors or where they can be placed. They may 
intersect or cross the slope, barriers, or other data 
collectors at any location. 

Adding a Data Collector 

To add a data collector to the model, select the Add Data 
Collector option from the toolbar or the Barriers menu.  

Select: Collectors → Add Data Collector 

1. Right-click the mouse and select Vertex Snap from the 
popup menu. 

2. Move the cursor near the lowermost slope vertex at 
(13.4, –25). The cursor should snap to the exact 
location of the vertex.  

3. Click the left mouse button to enter this as the first 
point of the data collector. 
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4. Now let’s enter the second point through the prompt 
line. 

Select location for the second endpoint
[esc=cancel]: 13.4 –17 

Your model should look like Figure 2-9. (The text and 
arrows were added with the Text Box and Arrow options 
in the Tools menu. This is left as an optional exercise). 

 

Figure 2-9: Data Collector added to model. 

As you can see, we have added a vertical data collector to 
the left of the existing barrier. 

Notice that the existing rock paths were reset when the 
data collector was added. This is done automatically by 
ROCFALL, since a new analysis is required whenever a 
barrier or a data collector is added to the model. 
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Compute 

Run the analysis by selecting the Compute option from 
the toolbar or the Rocks menu.  

Select: Rocks → Compute 

The calculation should only take a few seconds, and your 
screen should look similar to Figure 2-10. 

 

Figure 2-10: ROCFALL analysis with barrier and collector. 

As you can see, the data collector has no effect on the rock 
paths. 

We can now graph results for the data collector in exactly 
the same way that barrier results were graphed. 
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Graphing Data Collector Results 

Graphs for Barriers and Collectors can be generated using 
the Barrier and Collector Graphs option, available in the 
toolbar or the Graph menu. This was demonstrated 
earlier for the barrier graphs. 

An alternative to using this dialog, is to simply right-click 
on a barrier or collector, and select the desired graph. 
Let’s demonstrate this now. 

Right click on the collector, and select Graph Y-Impact 
Location from the popup menu. Your screen should look 
similar to Figure 2-11. 

 

Figure 2-11: Vertical Impact Location for Collector. 

Note that the impact locations are in terms of the absolute 
coordinates of your model, rather than relative 
coordinates (ie. measured from one end of the collector). 
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Statistics 
To view statistics for this graph, right click on the graph 
and select Statistics from the popup menu. You will see 
the following dialog. 

 

Figure 2-12: Collector statistics (Y-Impact location). 

Notice that the number of data points is 61, but we only 
simulated 50 falls.  

This is because collectors record data each time that a 
rock path crosses the collector. In this case, many of the 
rocks crossed the collector a second time, after bouncing 
off the barrier. 

In general, the number of data points recorded on a 
barrier or collector graph will not necessarily be equal to 
the number of rocks thrown, and will depend on how many 
times each rock path actually intersected the barrier or 
collector. 

When you are done viewing the Statistics dialog, click the 
OK button, and close the Graph window. 
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Filter Rock Paths 

ROCFALL has a feature for filtering rock paths with 
specified characteristics from other existing paths. Using 
the filtering options, you can view statistical information 
and distribution graphs for selected paths only. 

There are three ways of filtering rock paths: 

• Filter by Picking – this option allows you to 
graphically select rock paths in the Slope Profile view. 

• Filter by Value – this option filters rock paths based 
on either endpoint locations or path coordinates. 

• Filter by Impact – this option filters rock paths based 
on their characteristics, such as Total Kinetic Energy, 
Translational Velocity, etc., as they pass through 
collectors or as they impact on barriers. 

As an example, from the 50 rock paths in this tutorial, we 
will use the Filter by Impact option to single out the three 
rock paths that have the highest total kinetic energy, 
upon impact with Barrier001. 

Select: Rocks → Filter by Impact 

The Filter by Impact dialog appears. 

 

Figure 2–13: The Filter by Impact dialog. 
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In the dialog, choose Barrier001 from the list of barriers 
and collectors in the model. Pick the “Select paths with:” 
radio button. Next, choose Highest Total Kinetic Energy 
from the drop down list of characteristics that form the 
basis of filtering. Enter a value of 3 for the “Maximum 
number of paths” to be filtered.  

When you are done, press the “Apply Filter” button. Click 
Cancel to close the dialog. 

The filtered paths are displayed in a different colour in 
the slope view.  

We shall now view the Total Kinetic Energy graph and 
statistics for the paths that were filtered out.  

In the slope view, right-click on the barrier. Select Graph 
Total Energy from the ensuing popup menu. A graph of 
the Total Kinetic Energy of all paths in the analysis is 
shown on your screen. 

Tile the view so that both the Graph and Slope Profile 
views are visible on your screen. Next, right-click on the 
graph, and select Statistics from the popup menu. The 
Statistics dialog appears on your screen. 

Now we are ready to hide all other results and look at 
only information on the filtered paths.  

Select: Rocks → Filtered Paths Only 

Immediately, the two views and the Statistics dialog are 
updated to display information on the filtered paths only. 
Clicking the Filtered Paths Only option again causes all 
paths to be redisplayed. 
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Distribution Graphs vs. Collector Graphs 

To wrap up this tutorial, we will make an important point 
concerning Distribution Graphs and Collector Graphs in 
ROCFALL. 

In most cases, data collection is required along vertical 
lines at given X locations along the slope. For this 
purpose, the Graph Distribution option in the Graph 
menu allows you to plot: 

• Bounce Height 
• Total Kinetic Energy  
• Translational Kinetic Energy  
• Rotational Kinetic Energy 
• Translational Velocity, and  
• Rotational Velocity  

These graphs allow the user to quickly view distributions 
along the entire extent of the slope (see the Quick Start 
tutorial for details). 

Distribution Graphs are actually derived from a series of 
equally spaced “invisible” vertical data collectors 
automatically generated by ROCFALL when the analysis 
is run. The spacing of these collectors is determined by 
the Number of Sampling Intervals in the Project Settings 
dialog, and the total X extent of the slope. 

In most cases, the Distribution Graphs will provide the 
user with the desired data. The Data Collectors option 
described in this tutorial should only be necessary in the 
following cases: 

• If data collection along a non-vertical line is required, 
then Data Collectors must be used. 
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• If data collection at exact X locations is required, then 
it may be necessary to define Data Collectors, since 
the Distribution Graphs only provide results at the 
intervals determined by the Number of Sampling 
Intervals and the X extent of the slope. 
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Vertex Variation Tutorial 

 

In ROCFALL, standard deviations can be applied to the 
coordinates of any or all slope vertices. This allows the 
user to account for uncertainty in measurements, or to 
simulate a pseudo 3-D rockfall analysis (ie. to simulate 
minor variations in a slope profile). 

If you have not already done so, run ROCFALL by double-
clicking on the ROCFALL icon in your installation folder. 
Or from the Start menu, select Programs → Rocscience → 
RocFall → RocFall. If the ROCFALL application window 
is not already maximized, maximize it now, so that the 
full screen is available for viewing the model. 

This tutorial will also be based on the SIMPLE.FAL file, 
which you should find in the EXAMPLES folder in your 
ROCFALL installation folder. 

Select: File → Open 
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Navigate to the EXAMPLES folder in your ROCFALL 
installation folder, and open the SIMPLE.FAL file.  

We will now modify the SIMPLE.FAL file as follows. 

Edit Seeder 

First, let’s change the properties of the existing seeder. 
Right click the mouse on the existing point seeder (the 
blue cross at vertex (0 , 0) at the top of the slope), and 
select Edit Seeder from the popup menu. 

Change the Horizontal Velocity (Mean) to 3.5 and 
Horizontal Velocity (Std. Dev.) to 0. Leave all other 
properties as shown in Figure 3-1. Select OK. 

 

Figure 3-1: Changing the rock initial conditions. 

Notice that all standard deviations for the rock initial 
conditions are now zero. 

New Material 

Now, let’s create a new material with no deviation in 
material properties, and apply this material to the entire 
slope. 
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Select Material Editor from the toolbar or the Slope menu. 

Select: Slope → Material Editor 

 

Figure 3-2: New material added in Material Editor dialog. 

Define a new material called No Deviation as follows: 

1. Select the Add button in the Material Editor dialog, 
and notice that “New Material” appears in the 
Existing Materials list. 

2. Change the name of this new material to “No 
Deviation” and enter the properties shown below. 

Name 
Rn 

(mean | 
sd) 

Rt 
(mean | 

sd) 

Phi 
(mean | 

sd) 

Rough-
ness (sd) Color 

No Deviation 0.4 | 0 0.8 | 0 30 | 0 0 Black 

Table 3-1: New material properties. 

3. When you are finished entering the properties, select 
the Done button in the Material Editor dialog. 

You are now ready to assign the new material to the 
slope. 



54 ROCFALL User’s Guide 

 

Assign Material 
We will assign the new material to the entire slope, 
graphically using the mouse, as follows: 

1. Select the Assign toolbar button (the “paintbrush” 
button). 

2. Select the No Deviation material from the pull-down 
list of material names in the toolbar. 

3. Select the entire slope with a selection window (Click 
AND HOLD the left mouse button and drag to create 
a window that encloses the entire slope. When you 
release the mouse button, the material assignment 
will be made). 

4. Press the Enter key or right-click the mouse and 
select Done. 

Verify Changes 

Let’s quickly verify that we have correctly entered the 
new properties. Select Compute, and you should see only 
a single rock path travel down the slope. 

Select: Rocks → Compute 

Since we have removed all statistical variation (standard 
deviation = 0) for the rock (seeder) initial conditions, and 
the slope material properties, all rocks thrown should 
take the same path. If this is the case, select Clear Rock 
Paths from the Rocks menu, and continue with the 
tutorial. If this is NOT the case (ie. Multiple rock paths 
are displayed), then go back and check that you have 
entered the correct seeder and material properties. 
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Vertex Variation 

We are now ready to apply standard deviations to the 
slope vertices. Select Slope Editor from the Slope menu. 

Select: Slope → Slope Editor 

1. In the Slope Editor dialog, select the “Use standard 
deviations when generating slope vertices” checkbox. 
This will allow you to enter standard deviations for 
the vertex coordinates. 

2. For Vertex 3 ( mean coordinates = 6.7, –12.2) enter an 
X standard deviation = 0.05 and a Y standard 
deviation = 0.10. 

3. Select OK. 

 

Figure 3-3: Standard Deviation added to Vertex 3 in Slope Editor 
dialog. 

To keep things simple, we have only added standard 
deviation to a single vertex. This will make it easier to 
illustrate the effect of vertex variation in ROCFALL. 

Vertices with standard deviations are drawn with a 
yellow ellipse centered on the vertex, indicating the 
variability of the vertex location.  
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The ellipse indicates the range where approximately 95% 
of the sampled vertices will be generated, since the ellipse 
extends from the mean vertex location TWO standard 
deviations in both the positive and negative directions. 
(eg. a vertex at (0 , 0) with a standard deviation of 1 in the 
X direction and 2 in the Y direction, would be surrounded 
by an ellipse extending from X = – 2 to X = 2 , and Y = – 4 
to Y = 4 ). 

For this example, the ellipse is too small to be visible with 
the model at full scale, so let’s zoom in to get a closer look. 
Use the Zoom Window option to zoom in on vertex 3, until 
your screen looks approximately like Figure 3-4. 

 

Figure 3-4: Ellipse indicating variability of vertex location. 

(If you place the cursor directly over vertex 3 you will see 
the vertex “data tip”. Note the mean and standard 
deviations of the vertex coordinates are displayed.) 

Select Zoom All to bring the model back to full view. 
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Compute 

Now select Compute to run the analysis. 

Select: Rocks → Compute 

Your screen should look similar to Figure 3-5. 

 

Figure 3-5: ROCFALL analysis with vertex variation. 

As you can see, all rocks follow the same initial path, since 
there is zero variation in the seeder initial conditions.  

However, when they reach the second segment of the 
slope, many diverging paths are created, due to the 
variation we applied to vertex 3. 

Let’s zoom in again to see what is going on. Use Zoom 
Window (you may also find Zoom Mouse and Pan useful) 
to zoom in to the first bounce location to the left of vertex 
3, until your screen looks similar to Figure 3-6. 
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Figure 3-6: Zoom in on bounce location beside vertex 3. 

Figure 3-6 illustrates how the rocks can now bounce off of 
points above and below the mean slope segment 
orientation.  

Although only the mean slope segments are drawn, the 
rock paths indicate the range of actual slope segments 
generated by the statistical variation we applied to vertex 
3. Effectively, a new slope is generated before each rock is 
thrown. 

Note that the range of impact locations corresponds 
approximately to the extents of the ellipse (ie. If you 
visualize a segment joining vertex 2 to the ellipse extents 
around vertex 3, you can see that the upper and lower 
bounds of this segment would produce the impact 
locations we see after the analysis). 
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Sensitivity Analysis 
When using vertex variation in ROCFALL, you will 
probably find it most useful to change the standard 
deviation of only one vertex at a time (leaving all other 
vertices with a standard deviation of 0). This will allow 
you to determine the sensitivity of the simulation to the 
location of that particular vertex. If you change the 
standard deviation of many vertices at once it may be 
difficult to determine which vertex has the most effect on 
the results and which have very little effect. 
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