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 Introduction 

Introduction 
RocSupport is a quick and simple to use program for estimating 
the deformation of circular tunnels in weak rock, and visualizing 
the tunnel interaction with various support systems. 

The analysis method used in RocSupport is often referred to as 
“rock support interaction” or “convergence-confinement” analysis. 
This analysis method is based on the concept of a “ground reaction 
curve” or “characteristic line”, obtained from the analytical 
solution for a circular tunnel in an elasto-plastic rock mass under 
a hydrostatic stress field. 

Applicability of Method 

The main assumptions in the analysis method are as follows: 

• tunnel is circular 

• in-situ stress field is hydrostatic (i.e. equal stress in all 
directions) 

• rock mass is isotropic and homogeneous. Failure is not 
controlled by major structural discontinuities. 

• support response is elastic-perfectly plastic 

• support is modeled as an equivalent uniform internal pressure 
around the entire circumference of the circular tunnel 

This last assumption in particular (that support is uniform around 
the entire circumference of the tunnel), should be carefully 
considered by the user, when comparing actual tunnel behavior, 
and calculated results using RocSupport.  

The assumption of uniform support pressure implies that: 

• shotcrete and concrete linings are closed rings 

• steel sets are complete circles 

• mechanically anchored rockbolts are installed in a regular 
pattern which completely surrounds the tunnel. 

Because this will not usually be the case, actual support capacities 
will be lower, and deformations larger, than those assumed in 
RocSupport. 
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The idealized model used for a RocSupport analysis is not 
intended to replace detailed final design and analysis 
requirements for tunnel support. In general, this will require 
numerical analysis (e.g. finite element), particularly for tunnels 
with large strain. 

However, a great deal can be learned about the interaction of 
tunnels in weak rock, with various support systems, by carrying 
out parametric studies using RocSupport, in which different 
combinations of in-situ stress levels, rock mass strengths and 
support characteristics are evaluated. 

Methods of Support Design 

Although there are no clearly defined rules for tunnel support and 
lining design at the present time, three general methods have 
emerged over recent years. These can be described as: 

1. Closed form solution methods that are based upon the 
calculation of the extent of “plastic” failure in the rock mass 
surrounding an advancing tunnel, and the support pressures 
required to control the extent of the plastic zone and the 
resulting tunnel deformation. 

2. Numerical analysis of the progressive failure of the rock mass 
surrounding an advancing tunnel and of the interaction of 
temporary support and final lining with this failing rock mass. 

3. Empirical methods based upon observations of tunnel 
deformation and the control of this deformation by the 
installation of various support measures. 

RocSupport belongs to the first category of solution methods, i.e. 
“rock support interaction” or “convergence-confinement” methods. 

A good example of a numerical analysis program which belongs to 
the second category, is Phase2, a finite element stress analysis and 
support design program for underground excavations, also 
available from Rocscience. 

Each of these methods has advantages and disadvantages, and the 
optimum solution for a given tunnel design, may involve a 
combination of different methods, at different stages of the design. 
For example, a preliminary analysis of temporary support 
requirements could be carried out with RocSupport, and detailed 
final design, including plastic failure of the rock mass, and 
yielding support, can be carried out with Phase2. 
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In spite of the limitations discussed above, rock support 
interaction analysis has many attractions, and when used in 
conjunction with numerical analyses, it can provide valuable 
insights into the mechanics of rock support, and reasonable 
guidelines for the design of this support. 

Rock Support Interaction 

A starting point for a discussion of the “rock support interaction” 
method, is to discuss the deformation which occurs in the vicinity 
of an advancing tunnel face, for an unsupported tunnel. This is 
illustrated in the following figure. 

 

Figure 1-1: Radial displacements around an advancing tunnel face (not to 
scale). (Hoek, 1998). 
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Note that the radial displacement: 

• begins a certain distance ahead of the tunnel face (about two 
and one-half tunnel diameters) 

• reaches about one third of its final value AT the tunnel face 

• reaches its maximum value at about four and one-half tunnel 
diameters behind the face 

It is important to note that even for an unsupported tunnel, the 
tunnel face provides an “apparent support pressure”. It is this 
apparent support pressure that provides the stability to give 
sufficient stand-up time for the actual support to be installed. 

 

Figure 1-2: Support pressure pi at different positions relative to the advancing 
tunnel face (not to scale). (Hoek, 1999a) 

Observe that the apparent support pressure: 

• is equal to the in-situ stress (i.e. pi = po) at a certain distance 
(about two and one-half tunnel diameters) within the rock 
mass, ahead of the advancing face 

• is equal to about one-quarter of the in-situ stress, at the 
tunnel face 

• gradually reduces to zero at a certain distance behind the face. 
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Note that plastic failure of the rock mass surrounding a tunnel 
does not necessarily mean that the tunnel collapses. The failed 
material can still have considerable strength, and provided that 
the thickness of the plastic zone is small compared with the tunnel 
radius, the only evidence of failure may be a few fresh cracks and 
a minor amount of raveling or spalling. 

On the other hand, when a large plastic zone is formed and when 
large inward displacements of the tunnel wall occur, the loosening 
of the failed rock mass can lead to severe spalling and raveling 
and eventual collapse of an unsupported tunnel. 

The primary function of support is to control the inward 
displacement of the walls and to prevent the loosening, which can 
lead to collapse of the tunnel. The installation of support (e.g. 
rockbolts, shotcrete lining or steel sets) cannot prevent failure of 
the rock surrounding a tunnel subjected to significant 
overstressing, but these support types do play a major role in 
controlling tunnel deformation (Hoek et. al. 1995). 
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Ground Reaction Curve 
At the heart of the “rock support interaction” analysis method 
used in RocSupport, is the “ground reaction curve” or 
“characteristic line”, which relates internal support pressure to 
tunnel wall convergence. The general derivation of the ground 
reaction curve, is as follows. 

Assume that a circular tunnel of radius ro is subjected to 
hydrostatic in-situ stress po and a uniform internal support 
pressure pi, as illustrated in the margin figure. 

Failure of the rock mass surrounding the tunnel occurs when the 
internal pressure provided by the tunnel lining is less than a 
critical support pressure pcr. 

If the internal support pressure pi is greater than the critical 
support pressure pcr, no failure occurs, and the behaviour of the 
rock mass surrounding the tunnel is elastic. The inward radial 
elastic displacement of the tunnel wall is given by: 
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+
=

ν
 Eqn. 1.1 

When the internal support pressure pi is less than the critical 
support pressure pcr, failure occurs and a plastic zone of radius rp 
is formed around the tunnel. The inward radial plastic 
displacement uip is then defined by the ground reaction curve 
between pi = pcr  and pi = 0.  

A typical ground reaction curve is shown in Figure 1-3. 
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Figure 1-3: Ground reaction curve showing relationship between support 
pressure and tunnel wall convergence (Hoek et. al. 1995). 

This plot shows: 

• zero displacement when the support pressure equals the 
hydrostatic stress (pi = po) 

• elastic displacement uie for po > pi > pcr 

• plastic displacement uip for pi < pcr  

• maximum displacement when the support pressure equals 
zero 

For a given tunnel radius and in-situ stress, the shape of the 
ground reaction curve depends on the rock mass failure criterion 
which is assumed and the specific rock mass characteristics. 

The following are dependent on the rock mass failure criterion and 
characteristics: 

• the critical support pressure pcr 

• the radius of the plastic zone rp 

• the shape of the ground reaction curve in the plastic region (pi 
< pcr) 
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See the Solution Methods topic, later in this Introduction, for an 
overview of the two different solution methods used in 
RocSupport. These correspond to Mohr-Coulomb or Hoek-Brown 
rock mass failure criteria, and have been derived for the rock 
support interaction problem. 

Support Reaction 
In order to complete the rock support interaction analysis, the 
reaction curve for the rock support must be determined. This is a 
function of three components: 

1. The tunnel wall displacement that has occurred before the 
support is installed.  

2. The stiffness of the support system. 

3. The capacity of the support system. 

Referring back to Figure 1-1, remember that a certain amount of 
deformation takes place ahead of the advancing face of the tunnel. 
At the face itself, approximately one-third of the total deformation 
has taken place, and this cannot be recovered. In addition, there is 
almost always a stage of the excavation cycle in which there is a 
gap between the face and the closest installed support element. 
Therefore, further deformation occurs before the support becomes 
effective. This total initial displacement will be called uso and is 
shown in Figure 1-4. 
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Figure 1-4: Response of support system to tunnel wall displacement, resulting 
in establishment of equilibrium (Hoek et.al. 1995). 

Once the support has been installed and is in full and effective 
contact with the rock, the support starts to deform elastically as 
shown in Figure 1-4. The maximum elastic displacement which 
can be accommodated by the support system is usm and the 
maximum support pressure psm is defined by the yield of the 
support system. 

Depending upon the characteristics of the support system, the 
rock mass surrounding the tunnel and the in-situ stress level, the 
support system will deform elastically in response to the closure of 
the tunnel, as the face advances away from the point under 
consideration. 
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Rock-Support Equilibrium 

Equilibrium is achieved if the support reaction curve intersects 
the rock mass displacement curve before either of these curves 
have progressed too far. If the support is installed too late (i.e. uso 
is large in Figure 1-4), the rock mass may have already deformed 
to the extent that loosening of the failed material is irreversible. 
On the other hand, if the capacity of the support is inadequate (i.e. 
psm is low in Figure 1-4), then yield of the support may occur 
before the rock mass deformation curve is intersected. In either of 
these cases the support system will be ineffective, since the 
equilibrium condition, illustrated in Figure 1-4, will not have been 
achieved. 
Support Characteristics 

In RocSupport, the stiffness and capacity of support is expressed 

Note that since the support capacity is simply modeled as an 

n 

 length 

The stiffness and capacity of support systems such as rockbolts, 
 

 

in terms of Maximum Average Strain and Maximum Support 
Pressure. In this form it is incorporated directly into the rock 
support interaction analysis. 

equivalent internal pressure, the reinforcement provided by 
grouted rockbolts or cables cannot be properly accounted for i
this simple model. However, the radius of the plastic zone 
calculated from the analysis, can be used as a guide for the
of bolts or cables – i.e. bolts or cables should always be anchored in 
unyielded rock. 

steel sets, shotcrete and of combinations of these elements can be
estimated from relatively simplistic analyses published in Hoek 
and Brown (1980) and summarized in Hoek (1999b). These 
estimates have been used for the pre-defined support types 
available in RocSupport. 
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Support Installation 

The origin of the support reaction curve in Figure 1-4 (i.e. the 
value of uso), is the tunnel convergence which has occurred at the 
point of support installation. In RocSupport, this value can be 
specified in two ways: 

• directly (as a convergence or wall displacement), or 

• indirectly (a distance from the tunnel face is specified, which 
is then converted to tunnel convergence using a longitudinal 
tunnel deformation profile) 

The default tunnel deformation profile used in RocSupport is 
shown in Figure 1-5. The equation of this curve allows the user to 
input a value for distance from the tunnel face and obtain a value 
of wall displacement. In RocSupport, it is also possible to create a 
user-defined tunnel deformation profile. 

 

Figure 1-5: Tunnel wall displacement as a function of distance from face 
(Hoek, 1999a). 

Determination of the tunnel wall displacement that has occurred 
before the support is installed is not a trivial problem, since it 
involves a consideration of the three-dimensional stress 
distribution, and propagation of failure surrounding the 
advancing face. Chern et. al. (1998) published a set of results 
obtained from three-dimensional numerical analyses and also 
from measurements in an advancing tunnel where instruments 
had been installed from a parallel tunnel before excavation. Hoek 
(1999a) derived the curve in Figure 1-5 by averaging the results 
presented by these authors. 
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Solution Methods 
A number of derivations of the “rock support interaction” analysis 
method have now been published, as discussed in Hoek (1999a). 
All methods assume a circular tunnel in a hydrostatic stress field, 
and the main theoretical efforts have been devoted to the 
calculation of the size of the plastic zone, and the shape of the 
ground reaction curve, for different assumptions on how the 
failure of the rock mass progresses as the tunnel is advanced. 

The main differences between the various methods used to 
calculate the ground reaction curve, are in the choice of the rock 
mass failure criterion, and in whether or not the rock mass dilates 
(changes in volume) during failure. 

In RocSupport, two solution methods are available: the Duncan 
Fama method or the Carranza-Torres method. 

Duncan Fama Solution 

The Duncan Fama (1993) solution is based on the Mohr-Coulomb 
failure criterion, and allows the user to define the rock mass 
strength and deformation characteristics in terms of: 

• Rock mass compressive strength 

• Friction angle 

• Young’s modulus  

• Poisson’s ratio 

A useful outline of this solution method, is also presented in Hoek 
et. al. (1995). 

NOTE: although the Duncan Fama solution is based on the Mohr-
Coulomb failure criterion, estimates of the rock mass compressive 
strength and friction angle, can be obtained from Hoek-Brown 
strength parameters, as discussed in Example 1. 

Carranza-Torres Solution 

The Carranza-Torres (2004) solution is based on the Generalized 
Hoek-Brown failure criterion, and allows the user to define the 
rock mass strength and deformation characteristics in terms of: 

• Intact rock compressive strength (UCS) 

• Geological Strength Index (GSI) 

• Intact rock constant mi 
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• Dilation angle 

• Disturbance Factor (D) 

• Young’s modulus 

• Poisson’s ratio 

The Carranza-Torres solution can also account for residual 
strength, which is always specified directly in terms of the 
Generalized Hoek-Brown parameters mb, s and a. 

Deterministic Analysis 
In the toolbar or the Project Settings dialog, the user can choose 
either Deterministic or Probabilistic analysis types. 

 

A Deterministic analysis simply means that all input variables are 
assumed to be “exactly” known (e.g. in-situ stress and rock 
strength parameters). 

This results in a unique solution for all program output, including: 

• the Ground Reaction curve 

• Plastic Zone Radius 

• Equilibrium pressure (if support is installed) 

• Factor of Safety (for support) 
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Factor of Safety 

A unique Factor of Safety for the support is calculated in a 
Deterministic analysis. The definition of the Factor of Safety in 
RocSupport is as follows: 

• A Factor of Safety GREATER THAN 1 is calculated as shown 
in Figure 1-6. In this case the Factor of Safety is simply the 
ratio of the Maximum Support Pressure psm to the 
Equilibrium Pressure peq (the pressure at the intersection 
point of the Ground Reaction and Support Reaction curves). 

 

 

Figure 1-6: Definition of Factor of Safety > 1. 
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 A Factor of Safety LESS THAN 1 is calculated as shown in 
Figure 1-7. This occurs when the Ground Reaction curve 

 

 

•

intersects the Support Reaction curve after the elastic limit of 
the support has been exceeded. A “projected” equilibrium
pressure p'eq is calculated by projecting the elastic support 
reaction curve until it intersects the Ground Reaction curve,
and this value is used in the denominator of the Factor of 
Safety equation. 

 

 

Figure 1-7: Definition of Factor of Safety < 1. 
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Probabilistic Analysis 
In the toolbar or the Project Settings dialog, the user can choose 
either Deterministic or Probabilistic analysis types. 

 

A Probabilistic analysis allows the user to input statistical 
distributions for: 

• tunnel radius 

• in-situ stress 

• all rock mass parameters 

Using either Monte Carlo or Latin Hypercube sampling, the 
program will then sample the input distributions and run the 
analysis for the specified Number of Samples defined by the user 
in the Project Settings dialog. 

The user can then view statistical distributions of all output 
variables (e.g. plastic zone radius, wall displacement), rather than 
simply a single number as calculated from a Deterministic 
analysis. 

Probability of Failure 

A Probabilistic analysis results in a distribution of Safety Factor, 
rather than a single value. From a Safety Factor distribution, a 
Probability of Failure can be calculated. 

The Probability of Failure in RocSupport is simply the number of 
analyses with Safety Factor less than 1, divided by the total 
number of analyses generated by the Probabilistic analysis. 

For example, if 100 out of 1000 samples in a Probabilistic analysis 
resulted in a Factor of Safety less than 1, then the Probability of 
Failure would be 10 %. 
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Figure 1-8: Definition of Probability of Failure. 

Mathematically speaking, the Probability of Failure is the area 
under the Factor of Safety probability distribution to the LEFT of 
Factor of Safety = 1 (i.e. the black area in Figure 1-8), divided by 
the total area under the curve. 
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Example 1 – Medium Support 

 

Example 1 will demonstrate the basic features of RocSupport, and 
will use the Duncan Fama solution method to determine the 
Ground Reaction Curve. The tunnel will first be analyzed without 
support. Then support will be added, and a factor of safety for the 
support determined. Analysis will be Deterministic (all 
parameters assumed to be exactly known). 

MODEL FEATURES: 

• A 12 meter diameter tunnel is to be constructed at a depth of 
60 meters in a rock mass whose strength is defined by the 
Hoek-Brown criterion with an intact rock strength σci = 7 
MPa, constant mi = 10 and a Geological Strength Index = 15. 

NOTE: the finished product of this tutorial can be found in the 
example1.rsp data file in the EXAMPLES folder in your 
RocSupport installation folder. 
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Starting a Project 

If you have not already done so, start the RocSupport program by 
double-clicking on the RocSupport icon in your installation folder. 
Or from the Start menu, select Programs → Rocscience → 
RocSupport → RocSupport. 

If the RocSupport application window is not already maximized, 
maximize it now, so that the full screen is available for viewing 
the model. 

New File 
To begin creating a new model: 

Select: File → New 

When a new file is created, the Ground Reaction View will 
initially be displayed. This will show the Ground Reaction Curve 
based on the default Tunnel and Rock input data. 

If it is not already maximized, maximize the Ground Reaction 
View by selecting the Maximize button in the upper right corner of 
the view. 

 

Figure 2-1: Ground reaction curve for default input data. 
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Tunnel Section View 

To view a cross-sectional view of the model, select the Tunnel 
Section option from the toolbar or the Analysis menu. 

Select: Analysis → Tunnel Section 

The Tunnel Section View displays: 

• A cross-section of the tunnel diameter, and the plastic zone 
(shaded region). The size of the plastic zone is drawn to scale 
with respect to the tunnel diameter. 

• A Project Info Textbox with a summary of the main input and 
output parameters. The Textbox display can be toggled on or 
off in the right-click menu. The textbox position, colour and 
font can be customized by double-clicking on the textbox. 

• If support is installed, this will be displayed on the Tunnel 
Section View and the plastic zone radius (with support) will be 
displayed. 

 

Figure 2-2: Tunnel Section View for default input data (no support). 
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Project Settings 

Although we do not need to change any Project Settings for this 
example, let’s take a look at the Project Settings dialog. 

Select: Analysis → Project Settings 

 

Figure 2-3: Project Settings dialog. 

In the Project Settings dialog, you may enter: 

• A Project Title 

• Select the Solution Method and Analysis Type 

• Plot the Long Term Ground Reaction Curve 

See the Introduction to this manual for a discussion of the 
Solution Method and Analysis Type. See the last tutorial for a 
discussion of the Long Term Ground Reaction curve. 

For this example, we will use the default Project Settings, however, 
you may enter a Project Title – ROCSUPPORT EXAMPLE 1. 
Select OK. 
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Tunnel and Rock Parameters 

The tunnel diameter, in-situ stress and rock parameters are 
defined with the Tunnel Parameters option, which you may select 
from the toolbar or the Analysis menu. 

Select: Analysis → Tunnel Parameters 

For a Deterministic analysis, the Tunnel and Rock Parameters 
dialog will appear as shown below. Because we are using the 
Duncan Fama solution method, based on the Mohr-Coulomb 
failure criterion, the required Strength Properties are the rock 
mass Compressive Strength and Friction Angle. 

 

Figure 2-4: Tunnel and Rock Parameters dialog. 

Tunnel Radius 
NOTE that you must input the tunnel radius, and NOT the tunnel 
diameter, in the Tunnel and Rock Parameters dialog! 

For this example, the tunnel diameter is 12 meters, so enter a 
tunnel radius of 6 meters.  
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In-Situ Stress 
In the Tunnel and Rock Parameters dialog, you may input the 
hydrostatic in-situ stress directly, if it is known.  

However, as you will discover with other input data in 
RocSupport, whenever you see a “calculator” icon in an input data 
dialog, this means that the required input data may be estimated 
from other parameters. 

In the case of In-Situ Stress, this can be simply estimated from the 
tunnel depth and the rock unit weight. 

In the Tunnel and Rock Parameters dialog, select the Calculator 
icon to the right of the In-Situ Stress edit box. You will see the 
Estimate In-Situ Stress dialog. 

 

Figure 2-5: Estimate In-Situ Stress dialog. 

Enter a tunnel depth of 60 meters. We will use the default value for 
Unit Weight of Rock (0.027 MN / m3). Note that the estimated in-
situ stress (1.62 MPa) is displayed in the dialog. Select OK and the 
estimated value will be loaded into the Tunnel and Rock 
Parameters dialog. 

The estimated In-Situ Stress is simply the product of the Tunnel 
Depth and Unit Weight (Eqn. 2.1): 

 Hpo *γ=  Eqn. 2.1 

where: po = in-situ stress 

 γ = rock unit weight 

 H = tunnel depth below ground surface 
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Rock Parameters 
Now let’s enter the elastic and strength parameters for the rock.  

Remember at the beginning of this example, the rock properties 
were given in terms of Hoek-Brown parameters. However, the 
Duncan Fama solution method uses the Mohr-Coulomb failure 
criterion, and requires a Friction Angle. 

For this purpose, the “Calculate from GSI…” option is provided in 
the Tunnel and Rock Parameters dialog.  

 

If you select this button, you will see the following dialog. 

 

Figure 2-6: Parameter Calculator dialog. 

This dialog allows you to obtain estimates of the following rock 
mass properties: 

• Young’s Modulus 

• Compressive Strength 

• Friction Angle 

by entering values of the Hoek-Brown parameters GSI, mi, intact 
UCS and D. The ability to calculate these parameters is very 
useful because the rock mass modulus, compressive strength and 
friction angle are usually not very well known quantities, whereas 
GSI, intact mi, intact UCS are often more readily available 
parameters. 
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The calculations are based on the equations and methods 
presented in Hoek, Carranza-Torres and Corkum (2002). This 
paper presents the latest developments in the Hoek-Brown failure 
criterion, including an improved method of determining 
equivalent Mohr-Coulomb parameters from the Hoek-Brown 
failure envelope. 
For full details, the paper is available from the Rocscience website 

http://www.rocscience.com/library/pdf/RL_1.pdf

at the following link: 

 

In the Parameter Calculator dialog, enter the following values: 

and 
Intact UCS = 7, GSI = 15, Intact mi = 10. You should see the 
following output values for Young’s Modulus, rock mass UCS 
rock mass Friction Angle. 

 

TIP – you can use the checkboxes in the dialog to select which 
output variables will be calculated. This is useful if you only wi
to calculate some variables, and manually enter known values for 
other variables. 

sh 

Before you select OK, notice that beside each edit box is a “pick” 

 

In the Parameter Calculator dialog, select the “pick” button beside 
 

button. Whenever you see this icon displayed in a RocSupport 
dialog, this means that data can be selected or estimated from a
table or chart. Let’s examine this now. 

the GSI edit box. You will see the following GSI table, allowing you
to estimate a value for GSI based on the rock structure and surface 
conditions. 
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Figure 2-7: Built-in GSI table in RocSupport.  (Hoek, 1998). 

Note: 

• as you move the mouse around the chart, the GSI value at 
that point will be displayed beside the cursor 

• if you click the mouse at a point on the chart, the 
corresponding GSI value will be loaded into the edit box at the 
top of the GSI table 

• you may then edit this value, if necessary 

The significance and derivation of the Geological Strength Index 
will not be discussed in this manual. However, it should be 
emphasized that a parameter such as GSI should not be 
considered an exact value, and a range of possible values should 
always be considered in an analysis. For further information see 
Hoek et.al (1995) or Hoek (2004). 

Since we have already decided on a value for GSI, select Cancel in 
the GSI dialog. 
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Now select the “pick” button beside the “Intact Rock Constant mi” 
edit box. You will see the following dialog, allowing you to select a 
value for mi based on rock type. 

 

Figure 2-8: Pick Mi Value dialog. 

To use this dialog: 

• simply select a rock type from the list at the left of the dialog, 
and the corresponding mi value will be loaded into the edit box 
at the top of the dialog. 

• you may filter the list, if desired, by selecting the Rock Type 
and / or Texture checkboxes, and then selecting the desired 
Rock Type and / or Texture. This will display only the 
requested subset in the list. This is left as an optional exercise 
for the user to experiment with. 

Since we have already decided on a value for mi, select Cancel in 
the Pick Mi Value dialog. 

Select OK in the Parameter Calculator dialog, to return to the 
Tunnel and Rock Parameters dialog.  

The computed values of modulus, compressive strength and 
friction angle are automatically entered in the Tunnel and Rock 
Parameters dialog. Notice that the number of decimal places have 
been rounded appropriately for each parameter (e.g. decimal 
places are not warranted for the rock mass Young’s modulus!) 
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Apply 
We are now finished entering all of the desired data in the Tunnel 
and Rock Parameters dialog. 

In order to save the newly entered parameters, and re-run the 
analysis, you must select the Apply button. 

Select Apply in the Tunnel and Rock Parameters dialog. 

All analysis results in the Ground Reaction View and the Tunnel 
Section View will be updated with the new results. 

Close the dialog by selecting either the Close button, or the X in 
the upper right corner of the dialog.  

Remember that you must select Apply to save the data and re-run 
the analysis. If you select the Close button without FIRST 
selecting Apply, then this will cancel all new data entered, and the 
previous results will remain on the screen. 
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Analysis Results (No Support) 

If you are not already viewing it, switch to the Tunnel Section 
View. 

Select Zoom All to maximize the model within the view (you can 
also use the F2 function key to Zoom All): 

Select: View → Tunnel Section → Zoom All 

As can be seen in the summary provided in the Project Info 
Textbox: 

• the Plastic Zone radius (no support) = 13.8 m 

• the final Tunnel Convergence = 2.0 % 

 

Figure 2-9: Analysis with NO support. 

With an unsupported Tunnel Convergence of 2.0 %, this tunnel 
falls into “category B” according to the guidelines discussed in the 
Appendix, for a first estimate of support requirements. This 
indicates that appropriate support would involve rockbolts and 
shotcrete. See the Appendix for more information. 
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Ground Reaction Curve 
To view the Ground Reaction Curve, select the Ground Reaction 
option from the toolbar or the Analysis menu. 

Select: Analysis → Ground Reaction 

 

Figure 2-10: Ground reaction curve for Example 1. 

By default, the X-axis of the Ground Reaction Curve is expressed 
as Tunnel Convergence (%). The X-axis can also be displayed as 
Wall Displacement, using a convenient right-click shortcut. 

Right-click on the view and select Horizontal Axis > Wall 
Displacement from the popup menu. 

The X-axis of the Ground Reaction plot is now in terms of Wall 
Displacement rather than Tunnel Convergence.  

Right-click again on the view and select Horizontal Axis > Tunnel 
Convergence to reset the X-axis to Tunnel Convergence. 

Note: the horizontal axis of the Ground Reaction View can also be 
changed in the Display Options dialog. 
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Adding Support 

Now let’s add some rockbolt support, and see the effect on the 
tunnel behaviour. To add support, select the Support Parameters 
option from the toolbar or the Analysis menu. 

Select: Analysis → Support Parameters 

 

Figure 2-11: Support Parameters dialog. 

Based on the unsupported analysis results, what type of support 
would be appropriate for this problem?  

As described in the Appendix, this example problem, with an 
unsupported Tunnel Convergence of 2.0 %, falls into a category of 
tunneling problems, which can be stabilized with relatively 
modest support (e.g. rockbolts and shotcrete). 

For this example, we will start by adding 34 mm rockbolt support, 
at 1 x 1 m pattern spacing. Support will be installed at a distance 
of 3 m from the face. 
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To add the rockbolt support: 

1. Select the Add Support checkbox under the Rockbolts tab. 
Notice that a green checkmark now appears beside the 
Rockbolts tab, to indicate that rockbolt support will be in 
effect. 

2. We will use 34 mm rockbolts, which is already selected by 
default in the Type list. 

3. We will use the default Pattern Spacing = 1 x 1 meters. 

4. Enter Distance from Tunnel Face = 3. 

The dialog should appear as follows: 

 

Figure 2-12: Rockbolt support parameters for Example 1. 

5. Select the Apply button. This will save the support parameters 
you have entered, and re-run the analysis. All open views of 
the current document, will be updated with the latest analysis 
results. 
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Maximum Support Pressure and Strain 
Before we close the Support Parameters dialog, we will comment 
on the Maximum Support Pressure and Maximum Average Strain, 
which are displayed in the dialog. Note: 

 

• These values CANNOT be edited; they are pre-defined, 
calculated values (Hoek, 1999b) based on the support 
parameters you have selected.  

• For a given tunnel diameter, the Maximum Support Pressure 
depends on the type of support you have added, as well as the 
Out of Plane Spacing (for steel sets) or the Pattern Spacing 
(for rockbolts) 

• The Maximum Average Strain depends only on the support 
type you have selected, and is not affected by Out of Plane 
Spacing or Pattern Spacing. 

• If none of the pre-defined support types (Rockbolts, Steel Sets 
or Shotcrete), provide the required Support Pressure and 
Average Strain, then the user can simply define a Custom 
support type in the Support Parameters dialog. See the 
RocSupport Help system for details about defining Custom 
support. 

• Different support types (e.g. Rockbolts and Shotcrete) can be 
combined in the same analysis. This is discussed later in this 
tutorial. 

In this example, for the support parameters we have entered, 
Maximum Support Pressure = .354 MPa and Maximum Average 
Strain = 0.2 %. 

Now close the Support Parameters dialog (make sure you have 
selected Apply before you select Close), and we will discuss the 
results of the analysis with support. 
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Analysis Results (With Support) 

If the Tunnel Section View is not currently active, then select the 
Tunnel Section option from the toolbar or the Analysis menu, to 
view the Tunnel Section and analysis summary. 

 

Figure 2-13: Analysis with rockbolt support. 

Notice that there are now two plastic zone radius boundaries 
displayed (dotted lines). The interior boundary shows the extents 
of the plastic zone (shaded region) around the tunnel when 
support is installed. The outer boundary depicts the plastic zone 
when the problem is analyzed without support. 

When you place the mouse pointer in the shaded region, a tool tip 
appears that reads “Plastic zone: 10.01 m”.  When you move the 
pointer to the outer boundary the tip changes to “Unsupported 
plastic zone: 13.77 m”. 

The analysis summary in the Project Info textbox provides values 
of: 

• Factor of Safety 

• Mobilized Support Pressure 

• Plastic Zone Radius (decreased from 13.8 meters to 10.0 
meters with support) 
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• Tunnel Convergence (decreased from 2.0 % to 0.99 % with 
support) 

Factor of Safety 
The factor of safety for the rockbolts is 1.84. See the Introduction 
to this manual for a definition of the Factor of Safety in 
RocSupport. 

Although this would be considered an adequate Factor of Safety in 
other types of analyses (e.g. limit equilibrium slope stability), in a 
rock support interaction analysis this may not be the case, due to 
the assumptions inherent in the analysis. See the Introduction for 
more information. 

Mobilized Support Pressure 
The Mobilized Support Pressure listed in the Project Info Textbox 
is the Support Pressure determined from the intersection of the 
Ground Reaction and Support Reaction Curves, as shown in 
Figure 2-14 in the next section. 

When the Factor of Safety is greater than 1, this value will always 
be LESS than the Maximum (Available) Support Pressure. 

Plastic Zone Radius 
The rockbolt support has reduced the radius of the plastic zone 
from 13.8 meters to 10.0 meters. 

Note about Bolt Length 

Although bolt length does not enter into a RocSupport analysis 
(since support is modeled as an equivalent uniform internal 
pressure), the Plastic Zone Radius gives an indication of the 
required bolt lengths for effective support. For bolts to be effective, 
they must be anchored in unyielded rock. This means that they 
have to extend beyond the plastic zone.  

By default, RocSupport extends bolts 2.0 m beyond the plastic 
zone, when drawing the bolts on the screen. For the current 
example, this makes the rockbolt support approximately 6 meters 
in length. The default value of 2.0 m can be changed in the Section 
View tab of the Display Options dialog. 
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Ground Reaction and Support Reaction 

Now select the Ground Reaction view, which will display the 
Ground Reaction and Support Reaction curves on the same plot. 

Select: Analysis → Ground Reaction 

 

Figure 2-14: Ground reaction and support reaction curves. 

As discussed in the Introduction, note the following about the 
Support Reaction Curve: 

• The origin of the Support Reaction Curve, on the horizontal 
(Tunnel Convergence) axis, is determined from the Distance 
from Tunnel Face entered in the Support Parameters dialog. 
See the Introduction to this manual for details about how this 
value is determined. 

• The slope of the elastic portion of the Support Reaction curve, 
is equal to the Maximum Support Pressure divided by the 
Maximum Average Strain.  

• The intersection of the Support Reaction with the Ground 
Reaction, determines the mobilized support pressure, final 
tunnel convergence (with support) and plastic zone radius, 
listed in the Tunnel Section View. 
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If the Ground Reaction Curve intersects the Support Reaction 
Curve in the elastic region, as in this example, then the mobilized 
Support Pressure and Tunnel Convergence are considered 
EQUILIBRIUM values. 

Combining Support Types 

As mentioned earlier in this tutorial, the Support Parameters 
dialog allows multiple support types to be added for a given model.  

For example, Rockbolts and Shotcrete could be added to the same 
model, simply by selecting the Add Support checkbox for both 
Rockbolts and Shotcrete, and entering the desired parameters for 
each. 

When multiple support types are used for a single model, the 
following rules apply to the Maximum Support Pressure and 
Average Strain: 

• The Maximum Support Pressure is cumulative, and is ADDED 
for all applied support types. 

• The Maximum Average Strain is AVERAGED for all applied 
support types. 

These simplistic assumptions are of course not intended to model 
the actual, complex interaction of multiple support systems, but 
are an idealized approximation. 

For our current example, also remember that: 

• The guidelines described in the Appendix suggest that 
rockbolts and shotcrete together, would be appropriate 
support for this tunnel. 

So, let’s add some shotcrete support to the rockbolt support, and 
see the effect on the analysis results. 

Select: Analysis → Support Parameters 

In the Support Parameters dialog: 

1. Select the Shotcrete tab. 

2. Select the Add Support checkbox.  

3. Notice that green checkmarks now appear on BOTH the 
Rockbolts tab and the Shotcrete tab, indicating that both 
rockbolt and shotcrete support will be in effect.  
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4. Select the 50 mm thickness, 28-day age shotcrete type from 
the Properties list. 

The dialog should appear as follows: 

 

Figure 2-15: Shotcrete added in Support Parameters dialog. 

5. Select the Apply button, to save the shotcrete parameters and 
re-run the analysis. All open views of the current document, 
will be updated with the latest analysis results.   

Before we close the Support Parameters dialog, notice the 
Maximum Support Pressure and Maximum Average Strain values 
listed in the dialog. These are now the COMBINED values, for the 
rockbolts AND shotcrete. 

 

As discussed above: 

• the (combined) Maximum Support Pressure is the SUM of the 
34 mm rockbolt support pressure and the 50 mm shotcrete 
support pressure (.354 + .325 = .679) 
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• the (combined) Maximum Average Strain is the AVERAGE of 
the rockbolt and shotcrete maximum strain values (.200 + 
.100) / 2. 

Now close the dialog and observe the new analysis results. 

Note that the thickness of shotcrete (or steel set) support is not 
drawn to scale in the Tunnel Section View. If desired, it can be 
drawn either with a specified thickness in mm or as a percentage 
of tunnel radius, as selected in the Display Options dialog (use the 
Thickness of Support Layer option in the Section View tab of the 
Display Options dialog). This is left as an optional exercise for the 
user to experiment with. 

 

Analysis Results (With Combined Support) 

As we did after adding rockbolt support, examine the information 
in the Tunnel Section View and the Ground Reaction / Support 
Reaction View. The following table summarizes the results with 
No Support, Rockbolt Support, and Combined Rockbolt / Shotcrete 
Support. 

 No Support Rockbolts Rockbolts + 
Shotcrete 

Factor of 
safety 

n / a 1.8 3.2 

Mobilized 
support 
pressure 
(MPa)  

n / a .19 .21 

Plastic zone 
radius (m) 

13.8 10.0 9.7 

Tunnel 
convergenc
e (%) 

2.0 1.0 0.9 

Table 2-1: Summary of Example 1 analysis results. 

It can be seen that the addition of shotcrete support did not have a 
great effect on the plastic zone radius, tunnel convergence or 
mobilized support pressure, compared to the rockbolt support 
alone. 
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This is because the additional support capacity, in this case, has 
not significantly changed the intersection point of the Ground 
Reaction and Support Reaction curves, which determines these 
values. Compare Figures 2-14 and 2-16. 

However, the Factor of Safety for the combined support has been 
significantly increased, from 1.8 to 3.2. This might now be 
considered an adequate safety factor for the support system.  

Keep in mind that we used the 28-day shotcrete strength. The 
support pressure provided by the shotcrete at early ages is much 
less than the 28-day strength, and this must be taken into 
consideration when considering the actual combined safety factor, 
at different stages of the shotcrete curing. 

(Note that 3-day and 0.5-day 50 mm shotcrete support, is also 
available in the Support Parameters dialog). 

 

Figure 2-16: Ground reaction and combined rockbolt / shotcrete support 
reaction curves. 
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Info Viewer 

Finally, let’s look at the Info Viewer option. The Info Viewer 
option provides a well-formatted summary of all input and output 
data. 
Select: Analysis → Info Viewer 

 

Figure 2-17: Info Viewer display. 

If necessary, scroll down to view all of the information in the Info 

Notice that the Support Parameters information lists the Total 

 

The Info Viewer text can be copied to the Windows clipboard, by 
 

s 

The Info Viewer text can also be saved to a file, by right-clicking in 

That concludes this tutorial. To exit the program: 

Select: File → Exit 

Viewer. The font size can be changed in the View menu. 

Combined (Maximum Support Pressure and Maximum Average 
Strain), as well as the contributions from each individual support
type used in the model (in this case, rockbolts and shotcrete). 

selecting the Copy option from the Edit menu or the toolbar, or by
right-clicking in the Info Viewer and selecting Copy. From the 
Windows clipboard, the text can be pasted into other application
for report writing, presentations, etc. 

the view and selecting Save As .rtf file or Save As .txt file. A Rich 
Text Format file (.rtf file) preserves the formatting of the text, as 
it is displayed in the Info Viewer. A plain text file (.txt file) saves 
the text only, with no formatting. 
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Example 2 – Heavy Support 

 

Example 2 will model a tunnel with much more serious stability 
problems than Example 1, requiring heavier support. The 
Carranza-Torres solution method will be used to determine the 
Ground Reaction Curve. Analysis will be Deterministic (all 
parameters assumed to be exactly known). 

MODEL FEATURES: 

• A 10 meter diameter tunnel is to be constructed at a depth of 
75 meters in a rock mass whose strength is defined by the 
Hoek-Brown criterion with an intact rock strength σci = 4 Mpa, 
constant mi = 12 and a Geological Strength Index = 17. 

NOTE: the finished product of this tutorial can be found in the 
example2.rsp data file in the EXAMPLES folder in your 
RocSupport installation folder. 

If you have not already done so, start the RocSupport program, 
and create a new file to begin working with. 

Select: File → New 

If necessary, maximize the application window and the Ground 
Reaction View. 
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Project Settings 

For this example, we will use the Carranza-Torres solution 
method, which must be selected in the Project Settings dialog. 

Select: Analysis → Project Settings 

 

Figure 3-1: Project Settings dialog. 

In the Project Settings dialog, select the Carranza-Torres Solutio
Method. Enter a Project Title – ROCSUPPORT Example 2. S
OK. 

n 
elect 

nel and Rock Parameters dialog comes up. 
Any

par
you

Remember that: 

oek-
etermine the Ground Reaction 

Curve and plastic zone radius. 

d uses the Mohr-
Coulomb failure criterion, to determine the Ground Reaction 

stic zone radius. 

Immediately, the Tun
time you change from one solution method to the other this 

dialog is automatically invoked. This is because the input rock 
ameters for the two methods differ, making it necessary for 
 to verify that you are using the right values for analysis. 

• The Carranza-Torres (2004) solution method uses the H
Brown failure criterion, to d

• The Duncan Fama (1993) solution metho

Curve and pla
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Tunnel and Rock Parameters 

Our tunnel diameter is 10 meters, so the default Tunnel Rad
5 meters is already correct and does not need to be changed. 

ius of 

In-Situ Stress 
The In-Situ Stress can be estimated from the Tunnel Depth.  

1. Select the Estimate button beside the In-Situ Stress edit box.

2. Enter Tunnel Depth = 75 meters. Select OK in the Estimate 
In-Situ Stress dialog. 

3. The estimated In-Situ Stress is 2.02 MPa. 

Rock Parameters 

  

Enter the following Rock Parameters: 

Intact Rock Constant mi = 12, GSI = 17 and Compressive Strength 
of Intact Rock σci = 4.  

 

Figure 3-2: Tunnel and Rock Parameters for Example 2. 
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NOTE: built-in tables for selection of appropriate mi , GSI, intact 
UCS and D can be accessed by selecting the “pick” buttons in the 
Tunnel and Rock Parameters dialog. This is left as an optional 
exercise for the user to explore. See the previous tutorial for a 
discussion of these tables. 

Young’s Modulus 

You will notice that there is a calculator button beside the Young’s 
Modulus edit box.  

 

oung’s Modulus from strength parameters. Figure 3-3: Estimation of Y

If you select this button, the rock mass Young’s Modulus will be 
automatically calculated from the current values of GSI, intact 
UCS and Disturbance Factor. The equation used to calculate 
Young’s Modulus can be found in Hoek, Carranza-Torres and 
Corkum (2002). 

For this example, the rock mass Young’s Modulus is calculated to 
be 299 MPa. 

Apply 
Now select Apply to save the Tunnel and Rock Parameters you 
have entered, and run the analysis with the new parameters. 
Then select Close. 
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Analysis Results (No Support) 

The Ground Reaction curve should appear as follows. 

 

This is a very high value of Tunnel Convergence. As discussed in 

tability problems. Very heavy support, installed as 
close as possible to the advancing face, would be necessary. 

 Tunnel Section View. 

Figure 3-4: Ground Reaction curve, no support, Example 2. 

The final Tunnel Convergence = 13.1 % 

the Appendix, a tunnel with these input parameters would have 
very serious s

Select the

Select: Analysis → Tunnel Section 
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Figure 3-5: Tunnel section view, no support, Example 2. 

Notice the very large plastic zone radius (26.3 m) around the 
unsupported tunnel. 
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Adding Support 

For support, let’s start with I section steel sets (254 mm depth, 
203 mm width, weighing 82 kg / m), spaced at 1.5 m, and installed 
at a distance of 3 m from the face. 

Select: Analysis → Support Parameters 

 

Figure 3-6: Steel set support parameters. 

In the Support Parameters dialog: 

1. Select the Steel Sets tab, and select the Add Support checkbox. 

2. Select I section rib from the Type drop-down list. We will use 
the default selection 203 mm Flange Width. 

3. Enter Out of Plane spacing = 1.5, and Distance from Tunnel 
Face = 3. 

4. Select Apply to save the support parameters you have entered 
and re-run the analysis. Select Close. 
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Analysis Results (With Support) 

Select the Ground Reaction view. The Ground Reaction and 
Support Reaction should appear as follows: 

Figure 3-7: Ground reaction and support reaction. 

Select the Tunnel Section view, and view the analysis summary in 
the Project Info Textbox. 

 

Select: Analysis → Tunnel Section 

Compared to the unsupported results, the Steel Set support has: 

• decreased the plastic zone radius (26.3 to 18.2 m) 

• decreased the final Tunnel Convergence (13.1 to 6.0 %) 

• 

Even with support, the tunnel is still surrounded by a large plastic 

Factor of Safety for the Steel Sets indicates that the loading is 
well within the support capacity. 

Factor of safety for the support is 11.0 

Note: 

zone radius, and final convergence is still high. However, the 
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Additional Support 

Let’s now see the effect of adding a layer of shotcrete in addit
the steel set support. 

ion to 

Let’s look at the Ground Reaction / Support Reaction plot, to 
affected the final 

convergence or Plastic Zone Radius. 

eaction 

pport Reaction curve, to the curve 
for the Steel Sets alone (Figure 3-7), you will note the following: 

• the additional shotcrete support, has approximately doubled 
 of Safety 

increase from 11.0 to 24.9. 

• However, the intersection point of the Ground Reaction and 
d significantly, hence 

there is no significant change in the final Tunnel Convergence 
Plastic Zone radius. 

ace 

crete support. 

Select: Analysis → Support Parameters 

In the Support Parameters dialog, select the Shotcrete tab, select 
the Add Support checkbox, and select 100 mm thickness shotcrete. 
Note the combined Maximum Support Pressure (1.366) and 
Maximum Average Strain (0.18 %), of the shotcrete and the steel 
sets. 

Select Apply.  

NOTE: 

• The safety factor of the combined support system has more 
than doubled (11.0 to 24.9). 

• However, this has not significantly reduced the final Tunnel 
Convergence (which remains at 6.0 %) or the Plastic Zone 
Radius. 

examine why the shotcrete support has not 

Select: Analysis → Ground R

If we compare the combined Su

the Maximum Support Pressure, hence the Factor

Support Reaction curve, has not change

or 

In this example, the intersection of the Ground Reaction and 
Support Reaction is affected primarily by the Distance From F
(entered in the Support Parameters dialog). We did not change 
this value when we added the shot
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Figu

Support Installation 

re 3-8: Combined support reaction, steel sets and shotcrete. 

As a final exercise, enter different values for the Distance from
Face in the Support Parameters dialog (e.g. 2 meters, 1 meter
and select Apply to re-calculate and v

 
 etc), 

iew the results. 

e from Face shifts the origin of 
the Support Reaction curve. This DOES have an effect on final 

 
 

Face decreases, because the Support takes a greater load as it is 

Note: support installation can also be specified directly as a value 
of tunnel convergence or wall displacement. In this case, the 

Notice that changing the Distanc

Tunnel Convergence, Plastic Zone Radius, and Factor of Safety for
the Support. The Factor of Safety decreases as the Distance From

installed closer to the face. 

longitudinal deformation profile function is not used. 

 

Figure 3-9: Specifying support installation by tunnel convergence. 
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The user is encouraged to experiment with the Support 
Parameters dialog. Parametric analysis can be performed very 
quickly, by adding or removing support, changing support 
parameters, and selecting Apply to re-calculate the results. 
Observe the effects on the Support Reaction Curve. 

Comment on Example 2 

A tunnel with the input parameters used for this example, would 
certainly require very detailed final support design, which would 
include numerical analysis such as finite element. 

A rock-support interaction analysis of such a tunnel, as 
demonstrated here using RocSupport, would not be adequate for 
final design purposes. See the guidelines in the Appendix 
(“category E ”), for the expected support design issues for this 
tunnel. 

Nonetheless, valuable insight into the tunnel behaviour can be 
gained from the use of RocSupport even in such cases. Q
parametric analysis is very easy to perform in RocSuppo

uick 
rt, 

allowing the user to vary all input parameters, and view the effect 
on the results. 
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Exampl s e 3 – Probabilistic Analysi

 

This tutorial will demonstrate how to carry out a Probabilistic 
analysis with RocSupport.  

For a given tunneling problem, many of the input parameters are 
not known with accuracy, particularly those describing the rock 
mass characteristics. Therefore it is very useful to be able to input 
statistical distributions for input parameters, in order to obtain 
statistical distributions of the analysis results. 

MODEL FEATURES: 

This example will be based on the Example 1 problem, with 
statistical distributions entered for some of the input variables.  

NOTE: the finished product of this tutorial can be found in the 
example3.rsp data file in the EXAMPLES folder in your 
RocSupport installation folder. 
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Open File 

Open the Example 1 file. 

Select: File → Open 

 

e 
Navigate to your RocSupport installation folder, and open the 
Example1.rsp file. Note that RocSupport files have a .RSP filenam
extension. 
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Project Settings 

First we need to change the Analysis Type in the Project Settings 
dialog from Deterministic to Probabilistic. 

Select: Analysis → Project Settings 

 

Figure 4-1: Project Settings dialog, Example 3. 

In the Project Settings dialog, change the Analysis Type to 
Probabilistic, and change the Project Title to ROCSUPPORT 
Example 3. Select the Pseudo-Random Sampling option and click 
OK. 

We will examine the Pseudo-Random sampling option and its 
purpose later on in the tutorial. 

NOTE: the Analysis Type (Probabilistic or Deterministic) can also 
be selected from the toolbar, as shown below. 

 

Figure 4-2: Selecting the Analysis Type in the toolbar. 
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Tunnel and Rock Parameters 

Now select Tunnel Parameters from the toolbar or the Analysis 
menu. 

Select: Analysis → Tunnel Parameters 

Notice that the Tunnel and Rock Parameters dialog is presented 
in a grid format for a Probabilistic analysis. This simplifies the 
input of statistical parameters, and allows you to easily define 
random variables and keep track of which variables have been 
assigned statistical distributions. 

 

Figure 4-3: Tunnel and rock parameters dialog, probabilistic analysis. 

Random Variables 
To define a random variable, first select a statistical distribution 

ers 

which define the statistical 

nd Maximum 
 the mean, 

e relative minimum 
= 5 degrees and the relative maximum = 5 degrees. 

 See the RocSupport Help system for details about the various 
statistical distributions that are available in RocSupport, and 
the significance of the input parameters for each distribution. 

for the variable (e.g. Normal) in the Tunnel and Rock Paramet
dialog. Then enter the mean, standard deviation and relative 
minimum and maximum values, 
distribution for the variable. 

• It is important to note that the Minimum a
values are specified as RELATIVE distances from
rather than as absolute values. This simplifies the data input 
of these values. 

For example: if the mean Friction Angle = 25 degrees, and the 
minimum = 20 and maximum = 30, then th

•
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For this exa
random:  

mple, we will define the following variables as 

In-Situ stress 

ng’s Modulus 

Property Distribution Mean Std.Dev. Rel. Min. Rel. Max. 

• 

• You

• Compressive Strength 

• Friction Angle 

Enter the following data: 

In-Situ Stress Normal 1.62 .2 .6 .6 

Young’s 
Modulus 

Normal 353 50 150 150 

Compressive 
Strength 

Normal 0.47 .1 .3 .3 

Friction 
Angle 

Normal 25.64 2 6 6 

Table 4-1: Statistical input for random variables, example 3. 

The Tunnel and Rock Parameters dialog should appear as follows. 

 

Figure 4-4: Tunnel and Rock parameters, example 3. 
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Automatic Minimum and Maximum Values 

You may have noticed that the relative minimum and maximum 
l or each variable, was 3 times the standard 

deviation. For a Normal distribution, this ensures that a complete 
o ution is defined (i.e. since 99.7% of all 

samples fall within 3 standard deviations of the mean, for a 
r m variable). 

 t ock Parameters dialog, the following shortcut 
can be used for this purpose (this is left as an optional exercise to 

pleting this tutorial): 

1. Enter the standard deviation for a random variable. 

 ct t

va ue we entered f

(n n-truncated) distrib

no mally distributed rando

In he Tunnel and R

experiment with, after com

 

2. Sele he 
m and tive imu

You can us
just use

is short  for m

 button in the dialog, and the relative 
minimu  rela  max m for the variable will be 
automatically set to 3 times the standard deviation. 

e th cut ultiple variables simultaneously – 
 the mouse to first select all of the desired variables in the 

dialog, and then select the 3x button. 

Apply 
Now select Apply. This will save the parameters you have just 

analysis should only take a few seconds or less (remember that we 
entered, and run the RocSupport Probabilistic analysis. The 

used the default Number of Samples = 1000 in the Project Settings 
dialog). Close the Tunnel and Rock Parameters dialog, and we will 
view the analysis results. 

NOTE: because we selected Pseudo-Random sampling, the 
Probabilistic analysis will always generate exactly the same 
results, for a given set of input parameters. To generate true 
random sampling, we can turn OFF the Pseudo-Random Sampling 
option, as described later in this example. 
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Tunnel Section View 

Select the Tunnel Section View. 

Select: Analysis → Tunnel Section 

The Tunnel Section View, for a Probabilistic analysis, appears the 
same as for a Deterministic analysis. However, in the analysis 

atistical analysis. 
In general, these MEAN values will NOT NECESSARILY be 

the 
mean input data. 

•  as 
the MEAN safety factor. The Probability of Failure represents 
the  the 
support was less than 1, divided by the total number of 

summary provided in the Project Info Textbox, note that: 

• The results are the MEAN values from the st

the same as the Deterministic analysis results, based on 

A Probability o ailure, for the support, is listed, as well

 number of analyses, in which the Factor of Safety for

f F

analyses (1000 in this case).  

 

Figure 4-5: Tunnel Section view, probabilistic analysis. 

The Probability of Failure is currently zero (i.e. Factor of Safety is 
greater than 1 for all cases analyzed). 
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Statistics 

After a Probabilistic analysis, the user can plot the results in the 
form of Histograms, Cumulative Distributions or Scatter Plots of 
input and output variables. 

Histogram Plots 
To create a Histogram plot, select Histogram Plot from the toolbar 
or t

Sele

(Alt  also activate the Histogram Plot dialog by 

he Statistics menu. 

ct: Statistics → Histogram Plot 

ernatively, you can
pressing F7.) 

 

Figure 4-6: Plot Histogram dialog. 

Note that both input and output variables are listed in the 
Variable to Plot list. 

• The output variables will always include Factor of Safety, 
d Plastic Zone 

Radius. 

 be those for which you 
have entered a statistical distribution, in the Tunnel and Rock 
Parameters dialog. For our current example, this includes In-
Situ Stress, Young’s Modulus, UCS of Rock Mass and Friction 
Angle. 

Tunnel Convergence, Wall Displacement an

• The input variables listed, will only
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Let’s plot a histogram of Factor of Safety. Since this is the default 
selection in the Plot Histogram dialog, just select OK to generate 
the plot. 

Figure 4-7: Factor of safety histogram. 

As you can see in this plot, there were no analyses with a Factor of 
Safety less than 1. The Probability of Failure is therefore zero. 

For calculated output variables such as Factor of Safety, a 
FITTED distribution can be displayed on a histogram,
the above figure. The fitted distribution can be toggled on or off in 
the right-click menu, the Statistics menu or in the Plot Histogram
dialog (select the Show Fitted Distribution option). 

 

 as shown in 

 

The Fitted Distribution represents a best-fit distribution for the 
tically determined by RocSupport. 

Note that the Fitted Distribution can be any one of the statistical 
gular, 

normal or gamma). 

r 
exa

Select: Statistics → Histogram Plot 

In t
Var

output variable, and is automa

distributions used in RocSupport (i.e. normal, uniform, trian
beta, exponential, log

Now let’s generate a histogram of one of our input variables, fo
mple, In-Situ Stress. 

he Plot Histogram dialog, select In-Situ Stress from the 
iable to Plot list. Select OK. 
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Histogram plot, as shown in the above figure for In-Situ Stress. 
imulated values, and the 

parameters of the Input Distribution are provided at the bottom of 

• The Input Distribution is the distribution defined by the input 
ers 

rlo method in 
this case) of the Input Distribution you have defined. 

nd Input statistical parameters should 
be equal, or very nearly equal. This is because the Latin 

 input data distributions more 
uniformly than Monte Carlo sampling. This is left as an optional 

Figure 4-8: In-Situ stress histogram. 

For input variables, the Input Distribution can be displayed on the 

Also a statistical summary of the s

the plot. 

data you have entered in the Tunnel and Rock Paramet
dialog. 

• The Sampled data statistics are derived from the raw data 
generated by the statistical sampling (Monte Ca

This explains why the SAMPLED and INPUT statistical 
parameters listed at the bottom of an input variable histogram, 
will in general differ slightly, especially if the Number of Samples 
is small. 

(Note: if you use Latin Hypercube sampling, and a large number 
of samples, the Sampled a

Hypercube method samples the

exercise to explore, after completing this tutorial). 
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Cumulative Plots 
A cumulative distribution is, mathematically speaking, the 
integral of the normalized probability density function. Practically 
speaking, a point on a cumulative distribution gives the 
probability that a random variable will be LESS THAN OR 
EQUAL TO a specified value. 

To generate a Cumulative distribution, select Cumulative Plot 
from the toolbar or the Statistics menu. 

Select: Statistics → Cumulative Plot 

Note that the list of Variables to Plot, is exactly the same in both 
the Plot Histogram and Plot Cumulative dialogs. 

Let’s plot the Factor of Safety cumulative distribution. Since this is 
the default selection in the Plot Cumulative dialog, just select OK 
to generate the plot. 

 

Figure 4-9: Cumulative plot of Factor of Safety. 

afety = 
It is worthwhile noting that for the cumulative distribution of 
Factor of Safety, the cumulative probability at Factor of S
1, is equal to the Probability of Failure. In this example, the 
Factor of Safety is greater than 1 for all cases, therefore the 
Probability of Failure = 0.  
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Scatter Plots 
Scatter plots can also be generated after a probabilistic analysis. 
Scatter plots allow you to plot any two random variables against 
each other, to view the correlation (or lack of correlation) bet
the two variables.  

ween 

f Safety versus UCS of 

Select: Statistics → Scatter Plot 

In the Scatter plot dialog, select Factor o
Rock Mass. 

 

Figure 4-10: Scatter plot dialog. 

 

 strong correlation between the input 
variable UCS of Rock Mass, and the Factor of Safety for the 
support. The best fit linear regression line can be displayed using 
the right-click menu shortcut, if desired. 

Figure 4-11: Scatter plot of Factor of Safety versus rock mass UCS. 

It can be seen that there is a
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Computing the Analys  Random Sampling is using True

For this tutorial, we selected the Pseudo-Random Sampling option
in Project Settings. Therefore, when the Apply button is clicked in
the Tunnel Parameters or Support Parameters dialogs, 
RocSupport uses PS

 
 

EUDO-RANDOM numbers to generate the 
statistical sampling of the input variable distributions. Pseudo-

he SAME RESULTS each time the 
analysis is run. This allows the user to obtain reproducible results 

To run a Probabilistic analysis using TRUE RANDOM sampling, 
ling checkbox in 

ling of the input variable 

pling and 

 open. 
Close two of the views (for example, close the Ground Reaction 

random sampling generates t

for a Probabilistic analysis. 

then you must de-select the Pseudo-Random samp
the Project Settings dialog. 

With Pseudo-Random Sampling turned OFF, different random 
numbers are used to generate each samp
distributions. This means that EACH TIME COMPUTE or APPLY 
is selected, different results will be generated. 

We will re-run our example using true random sam
observe the results.  

Select: Analysis → Project Settings 

De-select the Pseudo-Random Sampling option and click OK. The 
analysis is immediately recomputed, and results different from 
the previous ones are displayed. 

To observe the effect on the Scatter Plot, select the Compute 
button several times. 

Select: Statistics → Compute 

The graph is updated after each Compute, to reflect the latest 
results. 

To further illustrate the results of using Compute with true 
random sampling, let’s tile the views. 

Select: Window → Tile Vertically 

If you have followed the steps in this tutorial, and did not have 
any other RocSupport files open, you should have six views

View and the Tunnel Section View, so that only the statistical plot 
views are open).  
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Select the Tile option again, and your screen sho
the figure below. 

uld look similar to 

 

 v

Additional Exercise 

Figure 4-12: Tiled iews, Example 3. 

Now again re-select Compute several times. Notice that all views 
are updated to reflect the latest results. 

Although we demonstrated the Probabilistic analysis features of 
RocSupport in this Example, the Probability of Failure was zero! 

As a final suggested exercise, we will create an example with a 
e 

itional graphing features of RocSupport.  

• remove the Shotcrete support completely, by clearing the 

y 

ty less than 1, are now highlighted in RED. 

3. View the In-Situ Stress Histogram. 

Probability of Failure greater than zero, in order to demonstrat
some add

1. In the Support Parameters dialog: 

Shotcrete checkbox 

• change the Rockbolt type to 19 mm rockbolt. Select Appl
and Close. 

2. View the Safety Factor Histogram. Notice that all bars with a 
Factor of Safe
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4. Select Show Failed Bars from the Statistics menu (or the 
right-click menu). The percentage of each bar of the 
histogram, corresponding to analyses with Factor of Safety 
less than 1, is now highlighted in RED. 

5. Repeat steps 3 and 4 for other input or output variables. 
Notice the distribution of failed analyses, with respect to the 
overall distribution of the variable. 

 

Figure 4-13: Failed results highlighted on in-situ stress histogram. 

 
the support system.  

The Show Failed Bars option allows the user to examine the 
relationship of any given input or output variable, to the failure of

That concludes this tutorial. To exit the program: 

Select: File → Exit 
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Lo tion ng Term Ground Reac

 

surrounding a tunnel, deteriorate over time, to some extent. This 
ishment 

of groundwater regimes, creep and similar phenomena (Hoek, 

n be accounted for by plotting a Long Term 
Ground Reaction curve, as selected in the Project Settings dialog.  

For this example, let’s first read in the Example 1 file, from the 
er in your RocSupport installation folder. 

 

The long-term behavior of a tunnel and support system is a very 
important aspect of tunnel design.  

It is often assumed that the long-term properties of the rock mass 

may be due to rock mass property deterioration, re-establ

2003). 

In RocSupport, this ca

Examples subfold
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Strength Reduction Factor 

The Long Term Ground Reaction option is selected in the Project 
Settings dialog. 

Select: Analysis → Project Settings 

Select the “Plot Long-Term Curve” checkbox. 

 

 is 
centage by which the following rock mass properties will be 

is 
 

 For the Carranza-Torres solution method, the reduction factor 
is applied to the Compressive Strength of the intact rock, and 
to the Young’s modulus. 

For this example, we will use the default reduction factor of 30%. 
Select OK in the Project Settings dialog. 

 

 

Figure 5-1: Long term ground reaction option in Project Settings. 

You can now enter a “strength reduction” factor (percent). This
the per
reduced, in order to determine the properties for the long term 
ground reaction curve: 

• For the Duncan Fama solution method, the reduction factor 
applied to the Compressive Strength of the rock mass, and to
the Young’s Modulus. 

•
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Long Term and Short Term Ground Reaction Curves 

In the Ground Reaction view, you will now see two Ground 
Reaction curves plotted: 

n curve is the lower curve, and is 
based on the original (un-reduced) material properties entered 

g. This can be 
referred to as the Short Term ground reaction curve. 

• The original Ground Reactio

in the Tunnel and Rock Parameters dialo

• The Long Term Ground Reaction curve is the upper curve, and 
is based on the reduction of material properties, as described 
in the previous section. 

 

Figu

As 
ground reaction curve with the support reaction curve, is different 
for 

Thi
and xample: 

re 5-2: Long term and short term ground reaction curves. 

you can see in the above figure, the intersection point of the 

the long term and the short term ground reaction. 

s will result in differing values of Final Tunnel Convergence 
 Factor of Safety. In this e

• The final tunnel convergence is increased slightly from .93% 
(short term) to .96% (long term) 
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• The greatest difference is in the Factor of 
reduced from 3.17 (short term) to 1.8 long

Safety, which is 
 term. This is the 

most significant result of using the long term ground reaction 

ater mobilized support pressure which is 
carried by the support over the long term. 

Inf

curve – the reduction of Factor of Safety for the support 
system, due to the gre

o Viewer 
For a summary of all available results for both the short term and 

Sele

long term ground reaction curves, check the Info Viewer. 

ct: Analysis → Info Viewer 

 

Figure 5-3: Summary of long term and short term results in Info Viewer. 
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Probabilistic Results rfo  Long Term Curve 

ou have are carrying out a Probabilistic Analysis in 
Support, then all of the probabilistic analysis output will be 
ilable for both the short and long term grou

If y
Roc
ava nd reaction curves. 
Try the following: 

xample 3 file, from the Examples subfolder in 
your RocSupport installation folder. 

m 
Curve” checkbox. 

3. Select the Plot Histogram option. Notice that the list of 

1. Read in the E

2. Select Project Settings and turn on the “Plot Long Ter

variables to plot, now includes all of the analysis output for 
the long term curve, as shown in the dialog below. 

 

4. In the Plot Histogram dialog, select Long-Term Factor of 
Safety, and select OK. You should see the following plot. 
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Conclusion 

Figure 5-4: Histogram of Long Term Safety Factor. 

Cumulative plots and Scatter Plots can also be created using the 
Long Term probabilistic analysis results. This is left as an 
optional exercise. 

e plotting of the Long Term Ground Reaction curve in 
RocSupport, can be a useful option for estimating the long term
performance of the tunnel and support system.  

However, the long term analysis as implemented in RocSupport
based on very simplistic assumptions, and should be used with

tion. The value which is entered for the Strength Reduction
 
 

Th
 

, is 

cau
he 

app
properties, is a subject which requires further research and 
investigation. 

 

 

 

 

 

factor will not be a well known parameter. And furthermore, t
lication of the reduction factor to the rock mass material 
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Appendix – First estimate of support 
requirements 

It has been demonstrated that the stability of tunnels in weak 
rock, is controlled by the ratio of the uniaxial compressive 
strength of the rock mass to the maximum in-situ stress. This 
ratio provides a guide to the first estimate of support 
requirements (Hoek, 1998).  
The results of the latest studies (Hoek and Marinos, 2000) are 
summarized in the following graph and corresponding table. 
Although the categories A to E are somewhat arbitrary, they are 
based on considerable experience, and are considered adequate as 
a first indication of tunneling difficulty. 

Note that this relationship is for an unsupported tunnel. Strain is 
defined as 100 x the ratio of tunnel closure to tunnel diameter. 

 

Figure A-1: Approximate relationship between strain and tunneling issue
squeezing rock. 

s in 
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 Strain ε % Geotechnical issues Support types 

 simple 
 can be 

Very simple tunneling 
conditions, with 

A Less than 1 Few stability problems and very
tunnel support design methods
used. Tunnel support rockbolts and shotcrete 
recommendations based upon rock 
mass classifications provide an 
adequate basis for design. 

typically used for 
support. 

Convergence confinement methods 
are used to predict the for

Minor squeezB 1 to 2.5 
mation of a 

'plastic' zone in the rock mass 

ing 
problems which are 
generally dealt with by 

 surrounding a tunnel and of the 
interaction between the progressive 
development of this zone and different 
types of support. 

rockbolts and shotcrete;
sometimes light steel 
sets or lattice girders 
are added for additional 
security. 

Two-dimensional finite element C 2.5 to 5 
analysis, incorporating support 

problem. Face stability is generally not 

Severe squeezing 
problems requiring rapid 

construction quality. 

elements and excavation sequence, 
are normally used for this type of 

installation of support 
and careful control of 

a major problem. Heavy steel sets 
embedded in shotcrete 
are generally required. 

The design of the tunnel is dominated 
by face stability issues and, while two-
dimensional finite analyses are 
generally carried out, some estimates 
of the effects of forepoling and face 
reinforcement are required. 

Very severe squeezing 
and face stability 
problems. Forepoling 
and face reinforcement 
with steel sets 
embedded in shotcrete 
are usually necessary

than Severe face instability as well as 
squeezing of the tunnel make this an 
extremely difficult three-dimensional 
problem for which no effective design 
methods are currently available. Most 
solutions are based on experience 

Extreme squeezing 
problems. Forepoling, 
face reinforcement are 
usually applied and 
yielding support may
required in extreme 
cases. 

D 5 to 10 

. 

E More 
10 

 be 

Table A-1: Approximate relationship between strain and tunneling issues. 
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